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Ansoft Maxwell Fundamentals

What is Maxwell?
Maxwell is a high-performance interactive software package that uses finite 
element analysis (FEA) to solve three-dimensional (3D) electric, magnetostatic, 
eddy current, and transient problems. 

Use it to compute:

Static electric fields, forces, torques, and capacitances caused by voltage 
distributions and charges.

Static magnetic fields, forces, torques, and inductances caused by DC 
currents, static external magnetic fields, and permanent magnets. 

Time-varying magnetic fields, forces, torques, and impedances caused by 
AC currents and oscillating external magnetic fields. 

Transient magnetic fields caused by electrical sources and permanent 
magnets
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Installing the Ansoft Maxwell Software

System Requirements
Microsoft Windows XP(32/64), Windows 2000, or Windows 2003 Server. For up-
to-date information, refer to the Maxwell Release Notes.

Pentium –based computer

128MB RAM minimum

8MB Video Card minimum

Mouse or other pointing device

CD-ROM drive

Installing the Ansoft Maxwell Software
For up-to-date information, refer to the Maxwell Installation Guide

Starting Ansoft Maxwell
1. Click the Microsoft Start button, select Programs, and select the Ansoft, Maxwell 

11 program group.  Click Maxwell 11.

2. Or Double click on the Maxwell 11 icon  on the Windows Desktop

NOTE:  You should make backup copies of all Maxwell projects created with 
a previous version of the software before opening them in Maxwell v11

WWW.MOHANDESYAR.COM

http://mohandesyar.com/


Ansoft Maxwell 3D Field Simulator v11 User’s Guide 5

Converting Older Files

Converting Older Maxwell file to Maxwell v11
Because of changes to the Maxwell files with the development of Maxwell v11, 
opening a Maxwell document from an earlier release may take more time than 
you are used to experiencing.  However, once the file has been opened and 
saved, subsequent opening time will return to normal

Ansoft Maxwell v11 provides a way for you to automatically convert your Maxwell 
projects from an earlier version to the Maxwell v11 format.  

To access Maxwell projects in an earlier version.

From Maxwell v11, 

1. Select the menu item File > Open
2. Open dialog

1. Files of Type:  Ansoft Legacy EM Projects (.cls)

2. Browse to the existing project and select the .cls file

3. Click the Open button
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Getting Help

Getting Help
If you have any questions while you are using Ansoft Maxwell you can find 
answers in several ways:

Ansoft Maxwell Online Help provides assistance while you are working.

To get help about a specific, active dialog box, click the Help button 
in the dialog box or press the F1 key.

Select the menu item Help > Contents to access the online help 
system.

Tooltips are available to provide information about tools on the 
toolbars or dialog boxes.  When you hold the pointer over a tool for a 
brief time, a tooltip appears to display the name of the tool.

As you move the pointer over a tool or click a menu item, the Status 
Bar at the bottom of the Ansoft Maxwell window provides a brief 
description of the function of the tool or menu item.

The Ansoft Maxwell Getting Started guide provides detailed 
information about using Maxwell to create and solve 3D EM projects.

Ansoft Technical Support

To contact Ansoft technical support staff in your geographical area, 
please log on to the Ansoft corporate website, www.ansoft.com and 
select Contact. 

Your Ansoft sales engineer may also be contacted in order to 
obtain this information.

Visiting the Ansoft Web Site
If your computer is connected to the Internet, you can visit the Ansoft Web site to 
learn more about the Ansoft company and products. 

From the Ansoft Desktop

Select the menu item Help > Ansoft Corporate Website to access 
the Online Technical Support (OTS) system.

From your Internet browser

Visit www.ansoft.com
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Getting Help

For Technical Support
The following link will direct you to the Ansoft Support Page.  The Ansoft Support 
Pages provide additional documentation, training, and application notes. 

Web Site: http://www.ansoft.com/support.cfm

Technical Support: 

9-4 EST: 

Pittsburgh, PA

(412) 261-3200 x0 – Ask for Technical Support

Burlington, MA

(781) 229-8900 x0 – Ask for Technical Support 

9-4 PST: 

San Jose, CA 

(408) 261-9095 x0 – Ask for Technical Support

Portland, OR

(503) 906-7944 or (503) 906-7947 

El Segundo, CA

(310) 426-2287 – Ask for Technical Support

WWW.MOHANDESYAR.COM

http://mohandesyar.com/


Ansoft Maxwell 3D Field Simulator v11 User’s Guide 8

WebUpdate

WebUpdate
This new feature allows you to update any existing Ansoft software from the 
WebUpdate window. This feature automatically scans your system to find any 
Ansoft software, and then allows you to download any updates if they are 
available. 
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Ansoft Terms

Ansoft Terms
The Ansoft Maxwell window has several optional panels:

A Project Manager which contains a design tree which lists the structure of 
the project.  

A Message Manager that allows you to view any errors or warnings that 
occur before you begin a simulation.

A Property Window that displays and allows you to change model 
parameters or attributes. 

A Progress Window that displays solution progress.

A 3D Modeler Window which contains the model and model tree for the 
active design.  For more information about the3D Modeler Window, see 
chapter 1.

Menu 
bar

Progress 
Window

Property Window

Message 
Manager

Project
Manager
with project
tree

Status 
bar

3D Modeler
Window

Toolbars

Coordinate Entry Fields
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Ansoft Terms

Project Manager 

Project

Design

Design Results

Design Setup

Design Automation
•Parametric
•Optimization
•Sensitivity
•Statistical

Project Manager Window
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Ansoft Terms

Property Window 

Property Window

Property tabs

Property 
buttons

Property 
table
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Ansoft Terms

Ansoft 3D Modeler 

Edge
Vertex

Plane
Coordinate System (CS)

Origin

Face
Model

3D Modeler Window

Graphics
area

Model

3D Modeler 
design tree

Context menu
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Ansoft Terms

3D Modeler Design Tree

Grouped by Material

Object View

Material

Object

Object Command History
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Design Windows

Design Windows
In the Ansoft Maxwell Desktop, each project can have multiple designs and each 
design is displayed in a separate window.

You can have multiple projects and design windows open at the same time.  
Also, you can have multiple views of the same design visible at the same time.

To arrange the windows, you can drag them by the title bar, and resize them by 
dragging a corner or border.  Also, you can select one of the following menu 
options: Window >Cascade, Window >Tile Vertically, or Window > Tile 
Horizontally.
To organize your Ansoft Maxwell window, you can iconize open designs.  Click 
the Iconize ** symbol in the upper right corner of the document border.  An icon 
appears in the lower part of the Ansoft Maxwell window.  If the icon is not visible, 
it may be behind another open document.  Resize any open documents as 
necessary.  Select the menu item Window > Arrange Icons to arrange them at 
the bottom of the Ansoft Maxwell window. 

Select the menu item Window > Close All to close all open design.  You are 
prompted to Save unsaved designs.

Design icons

Iconize
Symbol

WWW.MOHANDESYAR.COM

http://mohandesyar.com/


Ansoft Maxwell 3D Field Simulator v11 User’s Guide 15

Toolbars

Toolbars
The toolbar buttons are shortcuts for frequently used commands. Most of the 
available toolbars are displayed in this illustration of the Ansoft Maxwell initial 
screen, but your Ansoft Maxwell window probably will not be arranged this way.  
You can customize your toolbar display in a way that is convenient for you.

Some toolbars are always displayed; other toolbars display automatically when 
you select a document of the related type.  For example, when you select a 2D 
report from the project tree, the 2D report toolbar displays.

To display or hide individual toolbars:
Right-click the Ansoft Maxwell window frame.

A list of all the toolbars is displayed.  The toolbars with a check mark 
beside them are visible; the toolbars without a check mark are hidden.  
Click the toolbar name to turn its display on or off

To make changes to the toolbars, select the menu item Tools > Customize.  See 
Customize and Arrange Toolbars on the 
next page.

Toolbars

Ansoft 
Maxwell
panels
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Toolbars

Customize and Arrange Toolbars
To customize toolbars:

Select the menu item Tools > Customize, or right-click the Ansoft Maxwell 
window frame and click Customize at the bottom of the toolbar list.

In the Customize dialog, you can do the following:

View a Description of the toolbar commands

1. Select an item from the Component pull-down list

2. Select an item from the Category list

3. Using the mouse click on the Buttons to display the 
Description

4. Click the Close button when you are finished

Toggle the visibility of toolbars

1. From the Toolbar list, toggle the check boxes to control the 
visibility of the toolbars

2. Click the Close button when you are finished
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Overview

Ansoft Maxwell Desktop
The Ansoft Maxwell Desktop provides an intuitive, easy-to-use interface for 
developing passive RF device models.  Creating designs, involves the following:

1. Parametric Model Generation – creating the geometry, boundaries and 
excitations

2. Analysis Setup – defining solution setup and frequency sweeps

3. Results – creating 2D reports and field plots

4. Solve Loop - the solution process is fully automated

To understand how these processes co-exist, examine the illustration shown 
below.

Design

Solution Type

1.1. Boundaries

1.2. Excitations
4.1 Mesh 
Operations

2. Analysis
Solution Setup

Frequency Sweep

1. Parametric Model
Geometry/Materials

3. Results
2D Reports

Fields

Mesh
Refinement

Solve

Update

Converged

Analyze

Finished

4. Solve Loop

NO

YES
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Opening a Design

Opening a Maxwell project
This section describes how to open a new or existing project.

Opening a New project

To open a new project:

1. In an  Ansoft Maxwell window, select the menu item File > New.

2. Select the menu Project > Insert Maxwell Design.

Opening an Existing Maxwell project

To open an existing project:

1. In an Ansoft Maxwell window, 
select the menu File > Open.  
Use the Open dialog to select 
the project.

2. Click Open to open the project

Opening an Existing Project from Explorer

You can open a project directly from the Microsoft Windows Explorer.

To open a project from Windows Explorer, do one of the following:

Double-click on the name of the project in Windows Explorer.

Right-click the name of the project in Windows Explorer and select 
Open from the shortcut menu.
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Set Solution Type

Set Solution Type
This section describes how to set the Solution Type.  The Solution Type defines 
the type of results, how the excitations are defined, and the convergence.  The 
following Solution Types are available:

1. Magneto static - calculates the 

2. Eddy Current - calculates

3. Transient – calculates the

4. Electric – calculates the

Convergence

1. Magneto static -

2. Eddy Current -

3. Transient –

4. Electric –

To set the solution type:

1. Select the menu item Maxwell > Solution Type
2. Solution Type Window:

1. Choose one of the following:

1. Magnetostatic

2. Eddy Current

3. Transient

4. Electric

2. Click the OK button
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Parametric Model Creation
The Ansoft Maxwell 3D Modeler is designed for ease of use and flexibility.  The 
power of the 3D Modeler is in its unique ability to create fully parametric designs 
without editing complex macros/model history.

The purpose of this chapter is to provide an overview of the 3D Modeling 
capabilities.  By understanding the basic concepts outlined here you will be able 
to quickly take advantage of the full feature set offered by the 3D Parametric 
Modeler.

Overview of the 3D Modeler User Interface
The following picture shows the 3D Modeler window.

3D Modeler Design Tree – The 3D Modeler Design Tree is an essential part 
of the user interface.  From here you may access the structural elements in 
addition to any object dependencies and attributes.

Context Menus – Context menus are a flexible way of accessing frequently 
used menu commands for the current context.  The contents of these 
menus change dynamically and are available throughout the interface by 
clicking the right mouse button. 

Graphics Area – The graphics area is used to interact with the structural 
elements.

Graphics
area

Model

3D Modeler 
design tree

Context menu
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Overview of the 3D Modeler User Interface (Continued)
When using the 3D Modeler interface you will also interact with two additional 
interfaces:

Property Window – The Property Window is used to view or modify the 
attributes and dimensions of structural objects

Status Bar/Coordinate Entry – The Status Bar on the Ansoft Maxwell 
Desktop Window displays the Coordinate Entry fields that can be used to 
define points or offsets during the creation of structural objects

Property tabs

Property 
buttons

Property 
table
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Grid Plane
To simplify the creation of structural primitives, a grid or drawing plane is used.  
The drawing plane does not in any way limit the user to two dimensional 
coordinates but instead is used as a guide to simplify the creation of structural 
primitives.  The drawing plane is represented by the active grid plane (The grid 
does not have to be visible).   To demonstrate how drawing planes are used, 
review the following section: Creating and Viewing Simple Structures.

Active Cursor
The active cursor refers to the cursor that is available during object creation.  The 
cursor allows you to graphically change the current position.  The position is 
displayed on the status bar of the Ansoft Maxwell Desktop Window.  

When objects are not being constructed, the cursor remains passive and is set 
for dynamic selection.  See the Overview of Selecting Objects for more details.
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Creating and Viewing a Simple Structure
Creating 3D structural objects is accomplished by performing the following steps:

1. Set the grid plane

2. Create the base shape of the object

3. Set the Height

Create a Box

We will investigate creating a box to demonstrate these steps.  These steps 
assume that project and a Maxwell design have already been created.  
Three points are required to create the box.  The first two form the base 
rectangle and the third sets the height.

Point 1: Defines the start point of the base rectangle

Point 2: Defines the size of the base rectangle

Point 3: Defines the height of the Box

Point 2

Point 3

Point 1

Grid Plane

Base Rectangle
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Create a Box (Continued)

1. Select the menu item 3D Modeler > Grid Plane > XY
2. Use the mouse to create the base shape

1. Set the start point by positioning the active cursor and click the left 
mouse button.

2. Position the active cursor and click the left mouse button to set the 
second point that forms the base rectangle

3. Set the Height by positioning the active cursor and clicking left mouse 
button.
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Specifying Points
Grid

From the example, we saw that the simplest way to set a point is by 
clicking its position on the grid plane.  To set the precision of the grid plane, 
select the menu item View > Grid Settings. From here you may specify the 
Grid Type, Style, Visibility, and Precision.  By pressing the Save As Default
button, you can set the default behavior for future Maxwell Designs. 

Coordinate Entry

Another way to specify a coordinate is to use the Coordinate Entry fields 
which are located on the status bar of the Ansoft Maxwell Desktop.  The 
position may be specified in Cartesian, Cylindrical, or Spherical
coordinates.  Once the first point is set, the Coordinate Entry will default to 
Relative coordinates.  In Relative mode the coordinates are no longer 
absolute (measured from the origin of the working coordinate system), but 
relative to the last point entered.  

Equations 

The Coordinate Entry fields allow equations to be entered for 
position values.  Examples: 2*5, 2+6+8, 2*cos(10*(pi/180)).

Variables are not allowed in the Coordinate Entry Field

Note: Trig functions are in radians

Relative mode
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Specifying Points (Continued)
Object Properties

By default the Properties dialog will appear after you have finished 
sketching an object.  The position and size of objects can be modified from 
the dialog.  This method allows you to create objects by clicking the 
estimated values using the mouse and then correcting the values in the 
final dialog.  

The Property dialog accepts equations, variables, and units.  See the 
Overview of Entering Parameters for more detail.

Every object has two types of properties

1. Command – Defines the structural primitive

2. Attributes – Defines the material, display, and solve properties

Attributes

Commands
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Overview of Draw
Primitives

In solid modeling, the basic element or object is often called a primitive.  
Examples of primitives are boxes, cylinders, rectangles, circles, etc.  There 
are two types of primitives: 3D primitives or solids, and 2D primitives or 
surfaces.  By placing a collection of primitives in the correct location and of 
the correct size we can create a represent complex structural objects.  

To create complex objects, primitives can be used as “tools” to cut holes, 
carve away, or join.  The operations that are performed with these “tools”
are often referred to as Boolean operations.

2D primitives can be swept to create arbitrarily shaped solid primitives

2D Draw Objects

The following 2D Draw objects are available:

Rectangle, Circle, Line, Point, Spline, Ellipse, Regular Polygon (v10 
circle)

3D Draw Objects

The following 3D Draw objects are available:

Box, Cylinder, Sphere, Torus, Helix, Bond Wire, Cone, Regular 
Polyhedron (v10 cylinder)

True Surfaces

Circles, Cylinders, Spheres, etc are represented as true surfaces.  In 
versions prior to release 11, these primitives would be represented as 
faceted objects.  If you wish to use the faceted primitives (Cylinders or 
Circles), select the Regular Polyhedron or Regular Polygon.

To control the mesh generation of true surfaces objects, see the section on 
Mesh Control.
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Overview of Draw (Continued)

Snap Mode

As an aid for graphical selection, the 
modeler provides Snap options.  The 
default is to snaps are shown here.  The 
shape of the active cursor will dynamically 
change as the cursor is moved over the 
snap positions.

Moving

By default all active cursor movement is in three dimensions.  The modeler 
can also be set to allow the active cursor to only move in a plane or out of 
plane.  These are set from the menu item 3D Modeler > Movement Mode.

In addition, the movement can be limited to a specific direction (x, y, or z) 
by holding down the x, y, or z key.  This prevents movement in the other 
directions.

Pressing the CTRL+Enter key sets a local reference point.  This can be 
useful for creating geometry graphically that is based on an existing 
objects.  This is outlined on the next page:
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Moving (Continued)

Step 1: Start Point Step 2: Hold X key and select vertex point

Step 3: CTRL+Enter Keys set a local reference Step 4: Hold Z key and set height
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Overview of Draw
Import

In 3D modeler you can import a drawing file from outside.

Choose option 3D Modeler -> Import . Here is the list of import files that we 
support. For some of these import option you will need an add-on translator 
feature in your license file.

Healing

Automated healing for imported solid models

Post-translation user controlled healing

3D Model Analysis – 3D Modeler/Analyze

Face, Object , Area analysis based on user inputs

List of problems (faces, edges, vertices)

Auto Zoom In into region where problem exists

Remove Face

Remove Edge

Remove Sliver

Remove Vertices
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Selecting Previously Defined Shapes 
You may select an object by moving the mouse over the object in the graphics 
area and clicking on it.  The default mode is Dynamic selection which will display 
the object to be selected with a unique outline color.  Please note that after 
selecting (Clicking on the object) the object it will be displayed solid pink while all 
other objects are drawn transparent.  

Types of Selection

The default is to select objects.  Sometimes is necessary to select faces, 
edges, or vertices.  To change the selection mode, select the menu item 
Edit > Select and choose the appropriate selection mode.  The shortcut 
keys o (Object selection) and f (face selection) are useful for quickly 
switching between the most common selection modes

Multiple Select or Toggle Selection

Multiple objects can be selected graphically by holding down the CTRL key 
while selecting.  In addition, with the CTRL key pressed, the selection of an 
object can be toggled between selected or unselected.

Blocked Objects

If the object you wish to select is located behind another object, select the 
object that is blocking the desired object and press the b key or right-click 
and select Next Behind from the context menu.  You may repeat this as 
many times as needed to select the correct object.

Select All Visible

You can select all visible objects by pressing the CTRL+a key or by 
selecting the menu item Edit > Select All Visible.

Select by Name

To select objects by Name you can use anyone of the following:

Select the menu item Edit > Select > By Name
Select the menu item Maxwell > List

Select the Model tab

Select objects from the list

Use the Model Tree.  See the next page  
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Selecting Previously Defined Shapes (Continued)
Model Tree

After an object has been created, it is automatically added to the Model 
Tree.  All objects can be found in the Model Tree.  If you open the Model 
folder you will find the objects sorted by Object or by Material.  You can 
toggle between the views by toggling the menu item 3D Modeler > Group 
Object by Material.  

As stated previously, every object has two types of properties: 
Attributes

You may select an object by clicking on the corresponding 
item in the Model Tree.  
When the object is selected the attributes will be displayed in 
the Property Window.  Double-clicking on the object will open 
a properties dialog.  Use the Property Window or properties 
dialog to modify the attributes.

Commands 
From the Model Tree, the Command Properties can be 
selected by expanding the object folder to display the 
command list.  Using the mouse, select the corresponding 
command from the tree.  The properties will be displayed in 
the Property Window.  Double-clicking on the command will 
open a properties dialog.  Use the Property Window or 
properties dialog to modify the command.
When the command is selected, the object will be outlined 
with bold lines in the 3D Model Window.  Since an object can 
be a combination of several primitives, the command list may 
contain several objects.  Anyone of these commands can be 
selected to visualize or modify the object.

Attributes
Commands

Sorted by Object Sorted by Material
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Selecting Previously Defined Shapes (Continued)
Model Tree

Geometry in the 3D modeler is also grouped according to their model 
definition. Objects, Sheets, Lines, and Points are all separated so that they 
can be easily identified in the model tree

If a boundary condition or an excitation is defined on a sheet object, then 
those 2D objects will be further separated according to their assignment.
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Object Attributes
An objects attributes set the following user defined properties:

Name – User defined name.  Default names start with the primitive type
followed by an increasing number: Box1, Box2, etc.

Material – User defined material property.  The default property is vacuum.  
This can be changed by using the material toolbar

Solve Inside – By default Maxwell only solves for fields inside 
dielectrics.  To force Maxwell to solve inside conductors, check
solve inside.

Orientation

Model Object – Controls if the object is included in the solve

Display Wireframe – Forces the object to always be displayed as wireframe

Color – Set object color

Transparency – Set the transparency of an object.  0–Solid, 1- Wireframe

Note: Visibility is not an object property.
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Materials
By clicking on the property button for the material name, the material definition 
window will appear.  You can select from the existing database or define a 
custom project material.
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Materials (Continued)
User Defined Project Material

To define a custom material click the Add Material button from the material 
definition window.  The following dialog will appear.  Enter the material 
definitions and click the OK button.
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Changing the View
You can change the view at any time (even during shape generation) by using the 
following commands:

Toolbar

Rotate Model Center – The structure will be rotated around the Model

Pan – The structure will be translated in the graphical area

Dynamic Zoom – Moving the mouse upwards will increase the zoom factor 
while moving the mouse downwards will decrease the zoom factor

Zoom In/Out – In this mode a rubber band rectangle will be defined by dragging 
the mouse.  After releasing the mouse button the zoom factor will be applied.

Context Menu

Right click in the graphics area and select the menu item View and choose 
from the options outlined in the Toolbar section.  The context menu also offers 
the following:

Fit All – This will zoom the defined structure to a point where it fits in the 
drawing area

Fit Selection – This fits only the selected objects into the drawing area.

Spin – Drag the mouse and release the mouse button to start the object
spinning.  The speed of the dragging prior to releasing the mouse 
controls the speed of the spin.

Animate – Create or display the animation of parametric geometry

Shortcuts

Since changing the view is a frequently used operation, some useful shortcut 
keys exist.  Press the appropriate keys and drag the mouse with the left button 
pressed:

ALT + Drag – Rotate

In addition, there are 9 pre-defined view angles that can be 
selected by holding the ALT key and double clicking on the 
locations shown on the next page.

Shift + Drag - Pan

ALT + Shift + Drag – Dynamic Zoom

Pan

Rotate Dynamic Zoom

Zoom In/Out
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Shortcuts - Predefined Views
These 9 pre-defined views can be seen by holding the ALT key and double 
clicking the left mouse button on the locations shown below.

Top

Bottom

Right

Predefined View Angles

Left
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Changing the View (Continued)
Visibility

The visibility of objects, Boundaries, Excitations, and Field Reports can be 
controlled from the menu item View > Visibility

Hide Selection

The visibility of selected objects can be set hidden by selecting the 
object(s) and choosing the menu View > Hide Selection > All Views.

Rendering

To change the rendering select the menu item View > Render > Wireframe
or View > Render > Smooth Shaded

Coordinate System

To control the view of the coordinate system, select the menu item:

Visibility:

Toggle the menu item  View > Coordinate System > Hide 
(Show)

Size:

Toggle the menu item  View > Coordinate System > Small 
(Large)

Background Color

To set the background color, select the menu item View > Modify Attributes 
> Background Color

Addition View Seetings

Additional attributes of the view such as the projection, orientation, and 
lighting can be set from the menu item View > Modify Attributes
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Enhancements and New Features

Selection

Select Connected Vertices

Select Connected Faces

Select Connected Edges

Select Edge Chain 

Select Face Chain

Select Uncovered Loops

Healing

Purge History – makes an object appear as an 

imported entity so that healing can be 

performed on it

Remove Faces 

Remove Edges 

Remove Vertices

Align Faces
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Enhancements and New Features

Visibility

Hide selected objects in Active View

Hide selected objects in All Views

Show selected objects in Active View

Show selected objects in All Views

3D User Interface Options

When there is a selection

Selection is always visible

Set transparency of selected objects

Set transparency of non-selected objects

Default Rotation About

Screen Center

Current Axis

Model Center

3D Modeler Options

Visualize history of objects
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Applying Structural Transformations
So far we have investigated hot to model simple shapes and how to change the 
view of the model.  To create more complicated models or reduce the number of 
objects that need to be created manually we can apply various transformations.

The following examples assume that you have already selected the object(s) that 
you wish to apply a transformation.

You can select the transformation options from the menu item Edit >
Arrange >

Move – Translates the structure along a vector

Rotate – Rotates the shape around a coordinate axis by an angle

Mirror – Mirrors the shape around a specified plane

Offset – Performs a uniform scale in x, y, and z.

Duplicate >
Along Lines – Create multiple copies of an object along a vector

Around Axis – Create multiple copies of an object rotated by a fixed 
angle around the x, y, or z axis

Mirror - Mirrors the shape around a specified plane and creates a 
duplicate

Scale – Allows non-uniform scaling in the x, y, or z direction

The faces of an object can also be moved to alter the shape of an existing object.  
To move the faces of an object select the menu item 3D Modeler > Surfaces > 
Move Faces and select Along Normal or Along Vector.
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Combine Objects by Using Boolean Operations
Most complex structures can be reduced to combinations of simple primitives.  
Even the solid primitives can be reduced to simple 2D primitives that are swept 
along a vector or around an axis(Box is a square that is swept along a vector to 
give it thickness).  The solid modeler supports the following Boolean operations:

Unite – combine multiple primitives

Unite disjoint objects 

Separate Bodies to separate

Subtract – remove part of a primitive from another

Split – break primitives into multiple parts

Intersect– keep only the parts of primitives that overlap

Sweep – turn a 2D primitive into a solid by sweeping: Along a Vector, 
Around an Axis, Along a Path

Connect – connect 2D primitives.  Use Cover Surfaces to turn the 
connected object into a solid

Section – generate 2D cross-sections of a 3D object

Most Boolean operations require a base primitive in which the Boolean operation 
is performed.  Only the base object will be preserved.

The Boolean functions provide the option to Clone objects.

Split Crossing Objects – When a group of objects 

are selected, a Boolean split is performed on 

ANY objects that overlap
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Local Coordinate Systems
The ability to create local coordinate systems adds a great deal of flexibility to the 
creations of structural objects.  In previous sections we have only discussed 
objects that are aligned to the global coordinate system.  The local coordinate 
system simplifies the definition of objects that do not align with the global 
coordinate system.  In addition, the object history is defined relative to a 
coordinate system.  If the coordinate system is moved, the geometry will 
automatically move with it.  The definition of coordinate systems are maintained 
in the Model Tree.

Working Coordinate System

The working coordinate system is the currently selected CS.  This can be a 
local or global CS

Global CS

The default fixed coordinate system

Relative CS

User defined local coordinate system.

Offset

Rotated

Both

Face CS

User defined local coordinate system.  It is tied to the location of the object 
face it was created on.  If the size of the base object changes, all objects 
created relative to the face CS will be updated automatically.

Continued on Next Page
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Local Coordinate Systems (Continued)
Face CS (Continued)

To create a face CS, select the menu item 3D Modeler > Coordinate 
System > Face

1. Graphically select Face (Highlighted in model)

2. Select Origin for Face CS 

3. Set X-Axis

Step 1: Select Face Step 2: Select Origin

Step 3: Set X-Axis
New Working CS
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Cone is created with Face CS

Change the size of the box and 
the Cone is automatically 
moved with the Face CS

Local Coordinate Systems (Continued)
Example of Face CS

WWW.MOHANDESYAR.COM

http://mohandesyar.com/


1
Parametric Model Creation

1-47Ansoft Maxwell 3D Field Simulator v11 User’s Guide 

Parametric Geometry
The parametric modeler capability allows us to define variables in replace of a 
fixed position or size.  Once this has been defined the variable can be changed 
by the user or by Optimetrics.  Optimetrics can then be used to perform 
automatic Optimization, Parametric Sweeps, Statistical, or Sensitivity Analysis.  

Defining Parameters

Select the command to parameterized

Choose the value to change

Enter a variable in replace of the fixed value

Define the variable using any combination of math functions or design 
variables.

The model will automatically be updated
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Parametric Geometry (Continued)
Variables

There are two types of variables that can be defined in the Maxwell 
Desktop 

Design Properties – Local to model.  To access the local variables 
select the menu item Maxwell >  Design Properties
Project Variables – Global to all models in project. Start with $.  To 
access the global or project variables, select the menu item Project 
> Project Variables

Units

When defining variables they must contain units.  The default units 
for variables is meters.  

Equations

The variables can contain complex equations.  See the Online Help 
for a complete list of math functions

Equation based Curves and Surfaces

Any curve/surface that can be described 

by an equation in three dimensions 

can be drawn.

Animation

Right-Click in the 3D Model Window & Choose Animate to preview 
the parameterization

Note: depending on the quality of your graphics card you have the 
option of exporting ether AVI or GIF animation files.
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Boundary Conditions
This chapter describes the basics for applying boundary conditions.   Boundary 
conditions enable you to control the characteristics of planes, faces, or interfaces 
between objects.  Boundary conditions are important to understand and are 
fundamental to solution of Maxwell’s equations.

Why they are Important
The field equations that are solved by Ansoft Maxwell 3D are derived from the 
differential form of Maxwell’s Equations.   For these expressions to be valid, it is 
assumed that the field vectors are single-valued, bounded, and have continuous 
distribution along with their derivatives.  Along boundaries or sources, the fields 
are discontinuous and the derivatives have no meaning.  Therefore boundary 
conditions define the field behavior across discontinuous boundaries.

As a user of Ansoft Maxwell 3D you should be aware of the field assumptions 
made by boundary conditions.  Since boundary conditions force a field behavior 
we want to be aware of the assumptions so we can determine if they are 
appropriate for the simulation.  Improper use of boundary conditions may lead to 
inconsistent results.

When used properly, boundary conditions can be successfully utilized to reduce 
the model complexity.  In fact, Ansoft Maxwell 3D automatically uses boundary 
conditions to reduce the complexity of the model.  Ansoft Maxwell 3D can be 
thought of as a virtual prototyping  world.  Unlike the real world which is bounded 
by infinite space, the virtual prototyping world needs to be made finite.  In order to 
achieve this finite space, Ansoft Maxwell 3D applies a background or outer 
boundary condition which is applied to the region surrounding the geometric 
model.  

The model complexity usually is directly tied to the solution time and computer 
resources so it is a competitive advantage to utilize them whenever possible.
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Common Boundary Conditions
There are three types of boundary conditions.  The first two are largely the users 
responsibility to define them or ensure that they are defined correctly.  The 
material boundary conditions are transparent to the user.

1. Excitations

Wave Ports (External) 

Lumped Ports (Internal)

2. Surface Approximations

Symmetry Planes

Perfect Electric or Magnetic Surfaces

Radiation Surfaces

Background or Outer Surface

3. Material Properties

Boundary between two dielectrics

Finite Conductivity of a conductor
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How the Background Affects a Structure
The background is the region that surrounds the geometric model and fills any 
space that is not occupied by an object.  Any object surface that touches the 
background is automatically defined to be a Perfect E boundary and given the 
boundary name outer.  You can think of your structure as being encased with a 
thin, perfect conductor.

If it is necessary, you can change a surface that is exposed to the background to 
have properties that are different from outer:

To model losses in a surface, you can redefine the surface to be either a 
Finite Conductivity or Impedance boundary.  A Finite Conductivity 
boundary can be a lossy metal, with loss as a function of frequency and 
defined using conductivity and relative permeability parameters. An 
Impedance boundary has real or complex values that by default remain 
constant over frequency.

To model a surface to allow waves to radiate infinitely far into space, 
redefine the surface to be radiation boundary.

The background can affect how you make material assignments.  For example, if 
you are modeling a simple air-filled rectangular waveguide, you can create a 
single object in the shape of the waveguide and define it to have the 
characteristics of air.  The surface of the waveguide is automatically assumed to 
be a perfect conductor and given the boundary condition outer, or you can 
change it to a lossy conductor.
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Boundary Condition Precedence
The order in which boundaries are assigned is important in Maxwell 3D. Latter 
assigned boundaries take precedence over former assigned boundaries.

For example, if one face of an object is assigned to a Natural boundary, and a 
boundary in the same plane as this surface is assigned a Tangential H-Field  
boundary, then the Tangential H-Field will override the Natural in the area of the 
overlap. If this operation were performed in the reverse order, then the Tangential 
H-Field boundary would cover the Natural boundary.

Once boundaries have been assigned, they can be re-prioritized by selecting 
Maxwell > Boundaries > Re-prioritize. The order of the boundaries can be 
changed by clicking on a boundary and dragging it further up or down in the list. 
NOTE: Excitations will always take the highest precedence.
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Technical Definition of Boundary Conditions
Excitation – An excitation is a type of boundary condition that permits energy to 
flow into and out of a structure. See the section on Excitations.

Perfect E – Perfect E is a perfect electrical conductor, also referred to as a perfect 
conductor.  This type of boundary forces the electric field (E-Field) perpendicular 
to the surface. There are also two automatic Perfect E assignments:

Any object surface that touches the background is automatically defined to 
be a Perfect E boundary and given the boundary condition name outer.
Any object that is assigned the material pec (Perfect Electric Conductor) is 
automatically assigned the boundary condition Perfect E to its surface and 
given the boundary condition name smetal.

Perfect H – Perfect H is a perfect magnetic conductor.  Forces E-Field tangential 
to the surface.

Natural – for a Perfect H boundary that overlaps with a perfect E boundary, 
this reverts the selected area to its original material, erasing the Perfect E 
boundary condition. It does not affect any material assignments. It can be 
used, for example, to model a cut-out in a ground plane for a coax feed.

Finite Conductivity –A Finite Conductivity boundary enables you to define the 
surface of an object as a lossy (imperfect) conductor. It is an imperfect E 
boundary condition, and is analogous to the lossy metal material definition.  To 
model a lossy surface, you provide loss in Siemens/meter and permeability 
parameters.  Loss is calculated as a function of frequency.  It is only valid for 
good conductors.  Forces the tangential E-Field equal to Zs(n x Htan).  The 
surface impedance (Zs) is equal to, (1+j)/(δσ), where:

δ is the skin depth, (2/(ωσμ))0.5 of the conductor being modeled

ω is the frequency of the excitation wave.

σ is the conductivity of the conductor

μ is the permeability of the conductor
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Technical Definition of Boundary Conditions (Continued)
Impedance – a resistive surface that calculates the field behavior and losses 
using analytical formulas.  Forces the tangential E-Field equal to Zs(n x Htan).  
The surface impedance is equal to Rs + jXs, where:

Rs is the resistance in ohms/square

Xs is the reactance in ohms/square

Layered Impedance – Multiple thin layers in a structure can be modeled as an 
impedance surface.  See the Online Help for additional information on how to use 
the Layered Impedance boundary.

Lumped RLC – a parallel combination of lumped resistor, inductor, and/or 
capacitor surface.  The simulation is similar to the Impedance boundary, but the 
software calculate the ohms/square using the user supplied R, L, C values.

Infinite Ground Plane – Generally, the ground plane is treated as an infinite, 
Perfect E, Finite Conductivity, or Impedance boundary condition. If radiation 
boundaries are used in a structure, the ground plane acts as a shield for far-field 
energy, preventing waves from propagating past the ground plane. to simulate 
the effect of an infinite ground plane, check the Infinite ground plane box when 
defining a Perfect E, Finite Conductivity, or Impedance boundary condition. 
NOTE: Enabling the Infinite Ground Plane approximation ONLY affects post-
processed far-field radiation patterns. It will not change the current flowing on the 
ground plane.

Radiation – Radiation boundaries, also referred to as absorbing boundaries,
enable you to model a surface as electrically open: waves can then radiate out of 
the structure and toward the radiation boundary. The system absorbs the wave at 
the radiation boundary, essentially ballooning the boundary infinitely far away 
from the structure and into space.  Radiation boundaries may also be placed 
relatively close to a structure and can be arbitrarily shaped. This condition 
eliminates the need for a spherical boundary. For structures that include radiation 
boundaries, calculated S-parameters include the effects of radiation loss.  When 
a radiation boundary is included in a structure, far-field calculations are 
performed as part of the simulation.
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Technical Definition of Boundary Conditions (Continued)
Symmetry - represent perfect E or perfect H planes of symmetry. Symmetry 
boundaries enable you to model only part of a structure, which reduces the size 
or complexity of your design, thereby shortening the solution time. Symmetry 
boundaries, as opposed to a simple Perfect E or H plane, should be used when 
the plane cuts across a port. In this instance, the port has a different amount of 
power, voltage, and current associated with it, and thus a different impedance. To 
make a port with a symmetry plane look like a full-sized port, you must use the 
Impedance Multiplier in the boundary wizard.

For a single Symmetry H boundary, the Impedance Multiplier is 0.5.

For a single Symmetry E boundary, the Impedance Multiplier is 2.

Other considerations for a Symmetry boundary condition:

A plane of symmetry must be exposed to the background.

A plane of symmetry must not cut through an object drawn in the 3D 
Modeler window.

A plane of symmetry must be defined on a planar surface.

Only three orthogonal symmetry planes can be defined in a problem

Master / Slave - Master and slave boundaries enable you to model planes of 
periodicity where the E-field on one surface matches the E-field on another to 
within a phase difference. They force the E-field at each point on the slave 
boundary match the E-field to within a phase difference at each corresponding 
point on the master boundary. They are useful for simulating devices such as 
infinite arrays.  Some considerations for Master/Slave boundaries:

They can only be assigned to planar surfaces.

The geometry of the surface on one boundary must match the geometry 
on the surface of the other boundary. 
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Boundary Conditions
This chapter describes the basics for applying boundary conditions.   Boundary 
conditions enable you to control the characteristics of planes, faces, or interfaces 
between objects.  Boundary conditions are important to understand and are 
fundamental to solution of Maxwell’s equations.

Why they are Important
The field equations that are solved by Ansoft Maxwell 3D are derived from the 
differential form of Maxwell’s Equations.   For these expressions to be valid, it is 
assumed that the field vectors are single-valued, bounded, and have continuous 
distribution along with their derivatives.  Along boundaries or sources, the fields 
are discontinuous and the derivatives have no meaning.  Therefore boundary 
conditions define the field behavior across discontinuous boundaries.

As a user of Ansoft Maxwell 3D you should be aware of the field assumptions 
made by boundary conditions.  Since boundary conditions force a field behavior 
we want to be aware of the assumptions so we can determine if they are 
appropriate for the simulation.  Improper use of boundary conditions may lead to 
inconsistent results.

When used properly, boundary conditions can be successfully utilized to reduce 
the model complexity.  In fact, Ansoft Maxwell 3D automatically uses boundary 
conditions to reduce the complexity of the model.  Ansoft Maxwell 3D can be 
thought of as a virtual prototyping  world.  Unlike the real world which is bounded 
by infinite space, the virtual prototyping world needs to be made finite.  In order to 
achieve this finite space, Ansoft Maxwell 3D applies a background or outer 
boundary condition which is applied to the region surrounding the geometric 
model.  

The model complexity usually is directly tied to the solution time and computer 
resources so it is a competitive advantage to utilize them whenever possible.
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Common Boundary Conditions
There are three types of boundary conditions.  The first two are largely the users 
responsibility to define them or ensure that they are defined correctly.  The 
material boundary conditions are transparent to the user.

1. Excitations

Wave Ports (External) 

Lumped Ports (Internal)

2. Surface Approximations

Symmetry Planes

Perfect Electric or Magnetic Surfaces

Radiation Surfaces

Background or Outer Surface

3. Material Properties

Boundary between two dielectrics

Finite Conductivity of a conductor
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How the Background Affects a Structure
The background is the region that surrounds the geometric model and fills any 
space that is not occupied by an object.  Any object surface that touches the 
background is automatically defined to be a Perfect E boundary and given the 
boundary name outer.  You can think of your structure as being encased with a 
thin, perfect conductor.

If it is necessary, you can change a surface that is exposed to the background to 
have properties that are different from outer:

To model losses in a surface, you can redefine the surface to be either a 
Finite Conductivity or Impedance boundary.  A Finite Conductivity 
boundary can be a lossy metal, with loss as a function of frequency and 
defined using conductivity and relative permeability parameters. An 
Impedance boundary has real or complex values that by default remain 
constant over frequency.

To model a surface to allow waves to radiate infinitely far into space, 
redefine the surface to be radiation boundary.

The background can affect how you make material assignments.  For example, if 
you are modeling a simple air-filled rectangular waveguide, you can create a 
single object in the shape of the waveguide and define it to have the 
characteristics of air.  The surface of the waveguide is automatically assumed to 
be a perfect conductor and given the boundary condition outer, or you can 
change it to a lossy conductor.
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Boundary Condition Precedence
The order in which boundaries are assigned is important in Maxwell 3D. Latter 
assigned boundaries take precedence over former assigned boundaries.

For example, if one face of an object is assigned to a Natural boundary, and a 
boundary in the same plane as this surface is assigned a Tangential H-Field  
boundary, then the Tangential H-Field will override the Natural in the area of the 
overlap. If this operation were performed in the reverse order, then the Tangential 
H-Field boundary would cover the Natural boundary.

Once boundaries have been assigned, they can be re-prioritized by selecting 
Maxwell > Boundaries > Re-prioritize. The order of the boundaries can be 
changed by clicking on a boundary and dragging it further up or down in the list. 
NOTE: Excitations will always take the highest precedence.
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Technical Definition of Boundary Conditions
Excitation – An excitation is a type of boundary condition that permits energy to 
flow into and out of a structure. See the section on Excitations.

Perfect E – Perfect E is a perfect electrical conductor, also referred to as a perfect 
conductor.  This type of boundary forces the electric field (E-Field) perpendicular 
to the surface. There are also two automatic Perfect E assignments:

Any object surface that touches the background is automatically defined to 
be a Perfect E boundary and given the boundary condition name outer.
Any object that is assigned the material pec (Perfect Electric Conductor) is 
automatically assigned the boundary condition Perfect E to its surface and 
given the boundary condition name smetal.

Perfect H – Perfect H is a perfect magnetic conductor.  Forces E-Field tangential 
to the surface.

Natural – for a Perfect H boundary that overlaps with a perfect E boundary, 
this reverts the selected area to its original material, erasing the Perfect E 
boundary condition. It does not affect any material assignments. It can be 
used, for example, to model a cut-out in a ground plane for a coax feed.

Finite Conductivity –A Finite Conductivity boundary enables you to define the 
surface of an object as a lossy (imperfect) conductor. It is an imperfect E 
boundary condition, and is analogous to the lossy metal material definition.  To 
model a lossy surface, you provide loss in Siemens/meter and permeability 
parameters.  Loss is calculated as a function of frequency.  It is only valid for 
good conductors.  Forces the tangential E-Field equal to Zs(n x Htan).  The 
surface impedance (Zs) is equal to, (1+j)/(δσ), where:

δ is the skin depth, (2/(ωσμ))0.5 of the conductor being modeled

ω is the frequency of the excitation wave.

σ is the conductivity of the conductor

μ is the permeability of the conductor
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Technical Definition of Boundary Conditions (Continued)
Impedance – a resistive surface that calculates the field behavior and losses 
using analytical formulas.  Forces the tangential E-Field equal to Zs(n x Htan).  
The surface impedance is equal to Rs + jXs, where:

Rs is the resistance in ohms/square

Xs is the reactance in ohms/square

Layered Impedance – Multiple thin layers in a structure can be modeled as an 
impedance surface.  See the Online Help for additional information on how to use 
the Layered Impedance boundary.

Lumped RLC – a parallel combination of lumped resistor, inductor, and/or 
capacitor surface.  The simulation is similar to the Impedance boundary, but the 
software calculate the ohms/square using the user supplied R, L, C values.

Infinite Ground Plane – Generally, the ground plane is treated as an infinite, 
Perfect E, Finite Conductivity, or Impedance boundary condition. If radiation 
boundaries are used in a structure, the ground plane acts as a shield for far-field 
energy, preventing waves from propagating past the ground plane. to simulate 
the effect of an infinite ground plane, check the Infinite ground plane box when 
defining a Perfect E, Finite Conductivity, or Impedance boundary condition. 
NOTE: Enabling the Infinite Ground Plane approximation ONLY affects post-
processed far-field radiation patterns. It will not change the current flowing on the 
ground plane.

Radiation – Radiation boundaries, also referred to as absorbing boundaries,
enable you to model a surface as electrically open: waves can then radiate out of 
the structure and toward the radiation boundary. The system absorbs the wave at 
the radiation boundary, essentially ballooning the boundary infinitely far away 
from the structure and into space.  Radiation boundaries may also be placed 
relatively close to a structure and can be arbitrarily shaped. This condition 
eliminates the need for a spherical boundary. For structures that include radiation 
boundaries, calculated S-parameters include the effects of radiation loss.  When 
a radiation boundary is included in a structure, far-field calculations are 
performed as part of the simulation.
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Technical Definition of Boundary Conditions (Continued)
Symmetry - represent perfect E or perfect H planes of symmetry. Symmetry 
boundaries enable you to model only part of a structure, which reduces the size 
or complexity of your design, thereby shortening the solution time. Symmetry 
boundaries, as opposed to a simple Perfect E or H plane, should be used when 
the plane cuts across a port. In this instance, the port has a different amount of 
power, voltage, and current associated with it, and thus a different impedance. To 
make a port with a symmetry plane look like a full-sized port, you must use the 
Impedance Multiplier in the boundary wizard.

For a single Symmetry H boundary, the Impedance Multiplier is 0.5.

For a single Symmetry E boundary, the Impedance Multiplier is 2.

Other considerations for a Symmetry boundary condition:

A plane of symmetry must be exposed to the background.

A plane of symmetry must not cut through an object drawn in the 3D 
Modeler window.

A plane of symmetry must be defined on a planar surface.

Only three orthogonal symmetry planes can be defined in a problem

Master / Slave - Master and slave boundaries enable you to model planes of 
periodicity where the E-field on one surface matches the E-field on another to 
within a phase difference. They force the E-field at each point on the slave 
boundary match the E-field to within a phase difference at each corresponding 
point on the master boundary. They are useful for simulating devices such as 
infinite arrays.  Some considerations for Master/Slave boundaries:

They can only be assigned to planar surfaces.

The geometry of the surface on one boundary must match the geometry 
on the surface of the other boundary. 
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Magnetic Force
This example is intended to show you how to create and analyze a
magnetostatic problem with a permanent magnet to determine the force 
exerted on a steel bar using the Magnetostatic solver in the Ansoft Maxwell 
3D Design Environment.  
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Ansoft Maxwell Design Environment
The following features of the Ansoft Maxwell Design Environment are used to 
create the models covered in this topic

3D Solid Modeling

Primitives:  Box

Surface Operations:  Section 

Boolean Operations: Subtract, Unite, Separate Bodies

Boundaries/Excitations

Current: Stranded 

Analysis

Magnetostatic

Results

Force

Field Overlays:

Vector B
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Getting Started

Launching Maxwell
1. To access Maxwell, click the Microsoft Start button, select Programs, and select 

Ansoft and then Maxwell 11.

Setting Tool Options
To set the tool options:

Note:  In order to follow the steps outlined in this example, verify that the 
following tool options are set : 

1. Select the menu item Tools > Options > Maxwell Options
2. Maxwell Options Window:

1. Click the General Options tab

Use Wizards for data entry when creating new boundaries: 
Checked

Duplicate boundaries with geometry: Checked

2. Click the OK button

3. Select the menu item Tools > Options > 3D Modeler Options.
4. 3D Modeler Options Window:

1. Click the Operation tab

Automatically cover closed polylines: Checked

2. Click the Drawing tab

Edit property of new primitives: Checked

3. Click the OK button
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Opening a New Project
To open a new project:

In an  Ansoft Maxwell window, click the On the Standard toolbar, or 
select the menu item File > New.

From the Project menu, select Insert Maxwell Design.

Set Solution Type
To set the solution type:

Select the menu item Maxwell > Solution Type
Solution Type Window:

Choose Magnetostatic

Click the OK button
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Creating the 3D Model

Set Model Units
To set the units:

1. Select the menu item 3D Modeler > Units
2. Set Model Units:

1. Select Units: mm

2. Click the OK button

Set Default Material
To set the default material:

1. Using the 3D Modeler Materials toolbar, choose Select

2. Select Definition Window:

1. Type steel_1008 in the Search by Name field

2. Click the OK button
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Create Core
To create a box:

1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position

X: 0.0, Y: 0.0, Z: -5.0, Press the Enter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: 10.0, dY: -30.0, dZ: 10.0, Press the Enter key

To fit the view:

1. Select the menu item View > Fit All > Active View. 

Duplicate Box:

1. Select the menu item Edit > Duplicate Along Line
2. Using the coordinate entry fields, enter the first point

X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key

3. Using the coordinate entry fields, enter the second point

dX: 30.0, dY: 0.0, dZ: 10.0, Press the Enter key

4. Duplicate Along Line Window

1. Total Number: 2

2. Click the OK button

To create the core:

1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position

X: 0.0, Y: -30.0, Z: -5.0, Press the Enter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: 50.0, dY: -10.0, dZ: 10.0, Press the Enter key

To set the name:

1. Select the Attribute tab from the Properties window.

2. For the Value of Name type: Core

3. Click the OK button

To fit the view:

1. Select the menu item View > Fit All > Active View. 
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Group the Core
To select the objects

1. Select the menu item Edit > Select All
2. Select the menu item, 3D Modeler > Boolean > Unite

To fit the view:

1. Select the menu item View > Fit All > Active View.  

Duplicate the Core
To select the objects

1. Select the menu item, Edit > Duplicate Mirror
2. Using the coordinate entry fields, enter the first point

X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key

3. Using the coordinate entry fields, enter the normal point

dX: 0.0, dY: 1.0, dZ: 0.0, Press the Enter key

To fit the view:

1. Select the menu item View > Fit All > Active View.  

Group the Core
To select the objects

1. Select the menu item Edit > Select All
2. Select the menu item, 3D Modeler > Boolean > Unite

To fit the view:

1. Select the menu item View > Fit All > Active View.
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Create Bar
To create the bar:

1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position

X: 51.0, Y: -40.0, Z: -5.0, Press the Enter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: 10.0, dY: 80.0, dZ: 10.0, Press the Enter key

To parameterize the object:

1. Select the Command tab from the Properties window

2. For Position, type: 50mm+mx, -40,0, -5,0, Click the Tab key to accept 

Add Variable mx: 1mm, Click the OK button

To set the name:

1. Select the Attribute tab from the Properties window.

2. For the Value of Name type: Bar

3. Click the OK button

To fit the view:

1. Select the menu item View > Fit All > Active View. 

Set Default Material
1. Using the 3D Modeler Materials toolbar, choose Select

2. Select Definition Window:

1. Type copper in the Search by Name field

2. Click the OK button
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Create Coil
To create the coil:

1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position

X: 45.0, Y: 30.0, Z: 10.0, Press the Enter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: -20.0, dY: -60.0, dZ: -20.0, Press the Enter key

To set the name:

1. Select the Attribute tab from the Properties window.

2. For the Value of Name type: coil

3. Click the OK button

To select the object for subtract

1. Select the menu item Edit > Select > By Name
2. Select Object Dialog, 

1. Select the objects named: Coil, Core

2. Click the OK button

To complete the coil:

1. Select the menu item 3D Modeler > Boolean > Subtract 
2. Subtract Window

1. Blank Parts: Coil

2. Tool Parts: Core

3. Clone tool objects before subtracting: Checked

4. Click the OK button

To fit the view:

1. Select the menu item View > Fit All > Active View. 

Insulate Coil
To assign a boundary

1. Select the menu item Maxwell > Boundaries > Assign > Insulating
2. Insulating Boundary

1. Name: Insulating1

2. Click the OK button
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Create Excitation
Section Object

1. Select the menu item Edit > Surface > Section
1. Section Plane: XY

2. Click the OK button

Separate Bodies

1. Select the menu item Edit > Boolean > Separate Bodies
Assign Excitation

1. Select the menu item Maxwell > Excitations > Assign > Current
2. Current Excitation : General

1. Name: Current1

2. Value: c1

3. Type: Stranded

4. Current Direction: positive Z direction.  (Use Swap Direction button)

3. Click the OK button

4. Add Variable Window

1. Value: 100A

2. Click the OK button

Calculate Force
To select the object

Select the menu item Edit > Select > By Name
Select Object Dialog, 

Select the objects named: Bar

Click the OK button

Calculate Force

Select the menu item Maxwell > Parameters > Assign > Force
Click the OK button
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Set Default Material
1. Using the 3D Modeler Materials toolbar, choose Select

2. Select Definition Window:

1. Type NdFe35 in the Search by Name field

2. Click the OK button

Create Magnet
To create the magnet:

1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position

X: 0.0, Y: -10.0, Z: -5.0, Press the Enter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: 10.0, dY: 20.0, dZ: 10.0, Press the Enter key

To set the name:

1. Select the Attribute tab from the Properties window.

2. For the Value of Name type: Magnet

3. Click the OK button

To select the object for subtract

1. Select the menu item Edit > Select > By Name
2. Select Object Dialog, 

1. Select the objects named: Magnet, Core

2. Click the OK button

To complete the magnet:

1. Select the menu item 3D Modeler > Boolean > Subtract 
2. Subtract Window

1. Blank Parts: Core

2. Tool Parts: Magnet

3. Clone tool objects before subtracting: Checked

4. Click the OK button

To fit the view:

1. Select the menu item View > Fit All > Active View. 
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Orient Magnet
Note:  By default all of the magentic material in the material libaray are oriented in 
the x-direction.  Using a local coordinate system (CS) we can correct the orientation 
of the geometry to align with the material definition.

To create rotated CS:

1. Select the menu item Edit > Select > Faces
2. Using the mouse, graphically select the top face of the Magnet

3. Select the menu item 3D Modeler > Coordinate System > Create > Face CS

4. Using the coordinate entry fields, enter the origin

X: 10.0, Y: 10.0, Z: 5.0, Press the Enter key

5. Using the coordinate entry fields, enter the axis:

dX: 0.0, dY: -20.0, dZ: 0.0, Press the Enter key

Change Properties

1. Select the menu item Maxwell > List
2. Design List Window

1. From the list, select row: Magnet

2. Click the Properties button

3. Properties Window

1. Orientation: FaceCS1

2. Click the OK button

4. Click the Done button
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Set Default Material
To set the default material:

1. Using the 3D Modeler Materials toolbar, choose vacuum 

Define a Region 
To define a Region:

1. Select the menu item Draw > Region
1. Padding Date: One

2. Padding Percentage: 50

3. Click the OK button
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Analysis Setup

Creating an Analysis Setup
To create an analysis setup:

1. Select the menu item Maxwell > Analysis Setup > Add Solution Setup
2. Solution Setup Window:

1. Click the OK button

Save Project
To save the project:

1. In an  Ansoft Maxwell window, select the menu item File > Save As.

2. From the Save As window, type the Filename: maxwell_ms_magforce

3. Click the Save button

Analyze

Model Validation
To validate the model:

1. Select the menu item Maxwell > Validation Check
2. Click the Close button

Note: To view any errors or warning messages, use the Message 
Manager.

Analyze
To start the solution process:

1. Select the menu item Maxwell > Analyze All
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Solution Data
To view the Solution Data:

1. Select the menu item Maxwell > Results > Solution Data
To view the Profile:

1. Click the Profile Tab.

To view the Convergence:

1. Click the Convergence Tab

Note: The default view is for convergence is Table.  Select 
the Plot radio button to view a graphical representations of 
the convergence data.

To view the Solutions:

1. Click the Solutions Tab

2. Click the Close button
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Optimetrics Setup – Parametric Sweep
During the design of a device, it is common practice to develop design trends 
based on swept parameters.  Ansoft Maxwell 3D with Optimetrics Parametric 
Sweep can automatically create these design curves.

Add a Parametric Sweep
1. Select the menu item Maxwell > Optimetrics Analysis > Add Parametric
2. Setup Sweep Analysis Window:

1. Click the Sweep Definitions tab:

1. Click the Add button

2. Add/Edit Sweep Dialog

1. Select Variable: c1

2. Select Linear Count

3. Start: 0A

4. Stop: 500A

5. Step: 100

6. Click the Add button

7. Click the OK button

2. Click the Options tab:

1. Save Fields and Mesh: Checked

3. Click the OK button

Analyze Parametric Sweep
To start the solution process:

1. Expand the Project Tree to display the items listed under Optimetrics

2. Right-click the mouse on ParametricSetup1 and choose Analyze 

Optimetrics Results
To view the Optimetrics Results:

1. Select the menu item Maxwell> Optimetrics Analysis > Optimetrics Results
2. Select the Profile Tab to view the solution progress for each setup.

3. Click the Close button when you are finished viewing the results

WWW.MOHANDESYAR.COM

http://mohandesyar.com/


Ansoft Maxwell 3D Field Simulator  v11 User’s Guide 

5.1
Example (Magnetostatic) – Magnetic Force

5.1-81

Create Plot of Force at each Current
To create a report:

1. Select the menu item Maxwell > Results > Create Report
2. Create Report Window:

1. Report Type: Magnetostatic

2. Display Type: Rectangular Plot

3. Click the OK button

3. Traces Window:

1. Solution: Setup1: Force

2. Click the Sweeps tab

1. Select Sweep Design and Project variable values

2. Make sure that c1 is selected as the primary sweep

3. Click the Y tab

1. Category: Force

2. Quantity: Force_x

3. Function: <none>

4. Click the Add Trace button

4. Click the Done button
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The implementation and application of Nonlinear Inductor when 
using the Magnetostatic Solver

The nonlinear inductance is calculated by Maxwell.
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Ansoft Maxwell Design Environment
The following features of the Ansoft Maxwell Design Environment are used to 
create the models covered in this topic

3D Solid Modeling

Primitives:  Rectangular Box

Surface Operations:  Draw Rectangle 

Boolean Operations: Subtract

Boundaries/Excitations

Current: Stranded

Analysis

Magnetostatic

Results

Inductance Matrix

Field Overlays:

Flux Density Mapping
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Getting Started

Launching Maxwell
1. To access Maxwell, click the Microsoft Start button, select Programs, and select 

Ansoft and then Maxwell 11.

Setting Tool Options
To set the tool options:

Note:  In order to follow the steps outlined in this example, verify that the 
following tool options are set : 

1. Select the menu item Tools > Options > Maxwell Options
2. Maxwell Options Window:

1. Click the General Options tab

Use Wizards for data entry when creating new boundaries: 
Checked

Duplicate boundaries with geometry: Checked

2. Click the OK button

3. Select the menu item Tools > Options > 3D Modeler Options.
4. 3D Modeler Options Window:

1. Click the Operation tab

Automatically cover closed polylines: Checked

2. Click the Drawing tab

Edit property of new primitives: Checked

3. Click the OK button
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Opening a New Project
To open a new project:

1. In an  Maxwell window, click the On the Standard toolbar, or select 
the menu item File > New.

2. Select the menu item Project  > Insert Maxwell Design, or click on the    
icon

Set Solution Type
Select the menu item:  Maxwell > Solution Type > Magnetostatic, or right 
mouse click on MaxwellDesign1 and select Solution Type …

Creating the 3D Model of a Nonlinear Inductor
The example that will be used to demonstrate how to model the Nonlinear 
Inductor. By using 2 independent windings, we can observe the self 
inductance and mutual inductance. The inductance varies regard to the 
saturation level of the operation.

Set Model Units
Select the menu item 3D Modeler > Units > Select Units: mm (millimeters)

WWW.MOHANDESYAR.COM

http://mohandesyar.com/


5.2
Example (Magnetostatic) – Nonlinear Inductor

5.2-86Ansoft Maxwell 3D Field Simulator  v11 User’s Guide 

Create the Core: 
Box is used to create the core:

Draw > Box
1. Using the coordinate entry field, enter the corner of the box

X: 0, Y: 0, Z: 0, Press the Enter key

2. Using the coordinate entry field, enter the size of the box

dX: 10, dY: 10, dZ: 10, Press the Enter key

OK

The name of box is box1

Draw > Box
1. Using the coordinate entry field, enter the corner of the box

X: 0, Y: 1, Z: 1, Press the Enter key

2. Using the coordinate entry field, enter the size of the box

dX: 10, dY: 3, dZ: 8, Press the Enter key

OK

The name of box is box2

Draw > Box
1. Using the coordinate entry field, enter the corner of the box

X: 0, Y: 6, Z: 1, Press the Enter key

2. Using the coordinate entry field, enter the size of the box

dX: 10, dY: 3, dZ: 8, Press the Enter key

OK

The name of box is box3

Hold Ctrl key and Select: Box1, Box2, Box3
3D Modeler>Boolean>Subtract…
OK
The object name is Box1 since Box1 was selected first.

Click on the just created object in the drawing window and in the panel on 
the left change its name from Box1 to Core.

Change the Material from vacuum to Steel_1010.

Change the Color from Gray to Blue
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Create the Coils and Terminals: 
Box is used to create the coil:

Draw > Box
1. Using the coordinate entry field, enter the corner of the box

X: -2, Y: 2, Z: 2, Press the Enter key
2. Using the coordinate entry field, enter the size of the box

dX: 14, dY: 6, dZ: 1, Press the Enter key
OK
The name of box is box4

Draw > Box
1. Using the coordinate entry field, enter the corner of the box

X: -1, Y: 3, Z: 2, Press the Enter key
2. Using the coordinate entry field, enter the size of the box

dX: 12, dY: 4, dZ: 1, Press the Enter key
OK
The name of box is box5

Hold Ctrl key and Select: Box4, Box5
3D Modeler>Boolean₩>Subtract
OK
The object name is Box4 since Box4 was selected first.
Click on the just created object in the drawing window and in the panel on 
the left change its name from Box4 to CoilBottom.
Change the Material from vacuum to Copper.
Change the Color from Gray to Yellow.
Change the Transparent 0 to 0.1
Draw > Rectangle
Change the Draw plane from XY  to XZ

1. Using the coordinate entry field, enter the corner of the rectangle
X: 11, Y: 5, Z: 2, Press the Enter key

2. Using the coordinate entry field, enter the size of the rectangle
dX: 1, dY: 0, dZ: 1, Press the Enter key
OK
The name of rectangle is Rectangle1
Click on the just created object in the drawing window and in the 
panel on the left change its name from Rectangle1 to 
TerminalBottom..
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Create the Coils and Terminals: 
Select : CoilBottom, TerminalBottom
Edit>Duplicate>Along Line

1. Using the coordinate entry field, enter the first point of duplicate vector.

X: 0, Y: 0, Z: 0, Press the Enter key

2. Using the coordinate entry field, enter the second point of duplicate vector. 

dX: 0, dY: 0, dZ: 5, Press the Enter key

OK

Click on the just created object in the drawing window and in the 
panel on the left change its name from TerminalBottom_1 to 
TerminalTop.

Click on the just created object in the drawing window and in the 
panel on the left change its name from CoilBottom_1 to CoilTop.
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Create the problem Region
One of the main differences between Maxwell V10 and V11 is that a Background Region is not 
automatically created when a project is started.  A separate object needs to be specifically 
created.

Create a rectangular region that has the same shape as the Nonlinear Inductor by selecting the 
menu item Draw > Region

Padding Percentage: 200

Ok

Ok
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Assign Current Source to the Terminals
Select TerminalBottom.

Select the menu item Maxwell > Excitations > Assign > Current 
1. Change the Name to CurrentBottom

2. Change the value to 100 Amps

3. Change the type to Stranded

4. Ok
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Assign Current Source to the Terminals
Select TerminalTop.

Select the menu item Maxwell > Excitations > Assign > Current 
1. Change the Name to CurrentTop

2. Change the value to 100 Amps

3. Change the type to Stranded

4. Ok
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Add Inductance Matrix Calculation
On the Project Window, Right Click Parameters.

Assign > Matrix…
1. Check CurrentTop and CurrentBottom
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Create an Analysis Setup
Select the menu item Maxwell > Analysis Setup > Add Solution Setup
Select General and change the Percent Error from 1 to 2

Select Convergence and change the Refinement Per Pass from 30 to 20

WWW.MOHANDESYAR.COM

http://mohandesyar.com/


5.2
Example (Magnetostatic) – Nonlinear Inductor

5.2-94Ansoft Maxwell 3D Field Simulator  v11 User’s Guide 

Save the Project
Select the menu item File > Save As

From the Save As window, type in NonlinearInductance.

Click on the Save button

Check the Validity of the Model
Select the menu item Maxwell > Validation Check, or click on the          icon

The problem won’t solve unless each object has a check mark.

Analyze 
Select the menu item Maxwell > Analyze, or click on the         icon
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Solution Data
To view the Solution Data, select the menu item Maxwell > Results > Solution 
Data
Here you can view the Profile and the Convergence.  Note: The default view is for 
convergence is Table.  Select the Plot radio button to view a graphical 
representations of the convergence data.
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Observe the Inductance Matrix
Maxwell > Results> Solution Data…
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Plot Flux Density on Core Cross section
To plot the flux density on the core cross section, a new coordinate system is needed.

Here are the steps to create:

3D Modeler>Coordinate System>Create>Relative CS>Offset

Using the coordinate entry field, enter the position of the new coordinates:

X: 0, Y: 0, Z: 5, Press the Enter key

The name of new Coordinate is RelativeCS1

Select the plot plane: Planes>RelativeCS1:XY

Right mouse click: Field Overlays > Fields > B> Mag _B.
From the plot, we can see the flux density on core is around 1.86 Telsla. It is close to the 
saturation point of Steel_1010.

If we drive the inductor with much lower current, the operating point will be in the linear area. Then 
the inductance will be much higher than the inductance with operating point close to saturation 
point.
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Create a new project
Right Click on Project MaxwellDesign1> Copy

Click on NonlinearInductance>Paste.

A new project named MaxwellDesign2 is created.

Click Excitations: CurrentBottom, Change Current from 100 A to 1 A.

Click Excitations: CurrentTop, Change Current from 100 A to 1 A.

Right Click on Parameters>Assign>Matrix…

Check CurrentTop and CurrentBottom
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Run the new project and Observe the Inductance Matrix
Click on Analysis>Setup1
Right Click on Setup1: Analyze.
The simulation run and stop.

Maxwell > Results> Solution Data…
We can see the inductance is much higher than the previous simulation.
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Plot Flux Density on Core Cross section
Select the plot plane: Planes>RelativeCS1:XY

Right mouse click: Field Overlays > Fields > B> Mag _B.
From the plot, we can see the flux density on core is around 0.086 Telsla. It is working on the 
linear area of  Steel_1010.

WWW.MOHANDESYAR.COM

http://mohandesyar.com/


5.2
Example (Magnetostatic) – Nonlinear Inductor

5.2-101Ansoft Maxwell 3D Field Simulator  v11 User’s Guide 

The implementation and application of Nonlinear Inductor when 
using the Magnetostatic Solver

The nonlinear inductance is calculated by Maxwell.
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Ansoft Maxwell Design Environment
The following features of the Ansoft Maxwell Design Environment are used to 
create the models covered in this topic

3D Solid Modeling

Primitives:  Rectangular Box

Surface Operations:  Draw Rectangle 

Boolean Operations: Subtract

Boundaries/Excitations

Current: Stranded

Analysis

Magnetostatic

Results

Inductance Matrix

Field Overlays:

Flux Density Mapping
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Getting Started

Launching Maxwell
1. To access Maxwell, click the Microsoft Start button, select Programs, and select 

Ansoft and then Maxwell 11.

Setting Tool Options
To set the tool options:

Note:  In order to follow the steps outlined in this example, verify that the 
following tool options are set : 

1. Select the menu item Tools > Options > Maxwell Options
2. Maxwell Options Window:

1. Click the General Options tab

Use Wizards for data entry when creating new boundaries: 
Checked

Duplicate boundaries with geometry: Checked

2. Click the OK button

3. Select the menu item Tools > Options > 3D Modeler Options.
4. 3D Modeler Options Window:

1. Click the Operation tab

Automatically cover closed polylines: Checked

2. Click the Drawing tab

Edit property of new primitives: Checked

3. Click the OK button
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Opening a New Project
To open a new project:

1. In an  Maxwell window, click the On the Standard toolbar, or select 
the menu item File > New.

2. Select the menu item Project  > Insert Maxwell Design, or click on the    
icon

Set Solution Type
Select the menu item:  Maxwell > Solution Type > Magnetostatic, or right 
mouse click on MaxwellDesign1 and select Solution Type …

Creating the 3D Model of a Nonlinear Inductor
The example that will be used to demonstrate how to model the Nonlinear 
Inductor. By using 2 independent windings, we can observe the self 
inductance and mutual inductance. The inductance varies regard to the 
saturation level of the operation.

Set Model Units
Select the menu item 3D Modeler > Units > Select Units: mm (millimeters)
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Create the Core: 
Box is used to create the core:

Draw > Box
1. Using the coordinate entry field, enter the corner of the box

X: 0, Y: 0, Z: 0, Press the Enter key

2. Using the coordinate entry field, enter the size of the box

dX: 10, dY: 10, dZ: 10, Press the Enter key

OK

The name of box is box1

Draw > Box
1. Using the coordinate entry field, enter the corner of the box

X: 0, Y: 1, Z: 1, Press the Enter key

2. Using the coordinate entry field, enter the size of the box

dX: 10, dY: 3, dZ: 8, Press the Enter key

OK

The name of box is box2

Draw > Box
1. Using the coordinate entry field, enter the corner of the box

X: 0, Y: 6, Z: 1, Press the Enter key

2. Using the coordinate entry field, enter the size of the box

dX: 10, dY: 3, dZ: 8, Press the Enter key

OK

The name of box is box3

Hold Ctrl key and Select: Box1, Box2, Box3
3D Modeler>Boolean>Subtract…
OK
The object name is Box1 since Box1 was selected first.

Click on the just created object in the drawing window and in the panel on 
the left change its name from Box1 to Core.

Change the Material from vacuum to Steel_1010.

Change the Color from Gray to Blue
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Create the Coils and Terminals: 
Box is used to create the coil:

Draw > Box
1. Using the coordinate entry field, enter the corner of the box

X: -2, Y: 2, Z: 2, Press the Enter key
2. Using the coordinate entry field, enter the size of the box

dX: 14, dY: 6, dZ: 1, Press the Enter key
OK
The name of box is box4

Draw > Box
1. Using the coordinate entry field, enter the corner of the box

X: -1, Y: 3, Z: 2, Press the Enter key
2. Using the coordinate entry field, enter the size of the box

dX: 12, dY: 4, dZ: 1, Press the Enter key
OK
The name of box is box5

Hold Ctrl key and Select: Box4, Box5
3D Modeler>Boolean₩>Subtract
OK
The object name is Box4 since Box4 was selected first.
Click on the just created object in the drawing window and in the panel on 
the left change its name from Box4 to CoilBottom.
Change the Material from vacuum to Copper.
Change the Color from Gray to Yellow.
Change the Transparent 0 to 0.1
Draw > Rectangle
Change the Draw plane from XY  to XZ

1. Using the coordinate entry field, enter the corner of the rectangle
X: 11, Y: 5, Z: 2, Press the Enter key

2. Using the coordinate entry field, enter the size of the rectangle
dX: 1, dY: 0, dZ: 1, Press the Enter key
OK
The name of rectangle is Rectangle1
Click on the just created object in the drawing window and in the 
panel on the left change its name from Rectangle1 to 
TerminalBottom..
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Create the Coils and Terminals: 
Select : CoilBottom, TerminalBottom
Edit>Duplicate>Along Line

1. Using the coordinate entry field, enter the first point of duplicate vector.

X: 0, Y: 0, Z: 0, Press the Enter key

2. Using the coordinate entry field, enter the second point of duplicate vector. 

dX: 0, dY: 0, dZ: 5, Press the Enter key

OK

Click on the just created object in the drawing window and in the 
panel on the left change its name from TerminalBottom_1 to 
TerminalTop.

Click on the just created object in the drawing window and in the 
panel on the left change its name from CoilBottom_1 to CoilTop.
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Create the problem Region
One of the main differences between Maxwell V10 and V11 is that a Background Region is not 
automatically created when a project is started.  A separate object needs to be specifically 
created.

Create a rectangular region that has the same shape as the Nonlinear Inductor by selecting the 
menu item Draw > Region

Padding Percentage: 200

Ok

Ok
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Assign Current Source to the Terminals
Select TerminalBottom.

Select the menu item Maxwell > Excitations > Assign > Current 
1. Change the Name to CurrentBottom

2. Change the value to 100 Amps

3. Change the type to Stranded

4. Ok
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Assign Current Source to the Terminals
Select TerminalTop.

Select the menu item Maxwell > Excitations > Assign > Current 
1. Change the Name to CurrentTop

2. Change the value to 100 Amps

3. Change the type to Stranded

4. Ok
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Add Inductance Matrix Calculation
On the Project Window, Right Click Parameters.

Assign > Matrix…
1. Check CurrentTop and CurrentBottom
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Create an Analysis Setup
Select the menu item Maxwell > Analysis Setup > Add Solution Setup
Select General and change the Percent Error from 1 to 2

Select Convergence and change the Refinement Per Pass from 30 to 20
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Save the Project
Select the menu item File > Save As

From the Save As window, type in NonlinearInductance.

Click on the Save button

Check the Validity of the Model
Select the menu item Maxwell > Validation Check, or click on the          icon

The problem won’t solve unless each object has a check mark.

Analyze 
Select the menu item Maxwell > Analyze, or click on the         icon
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Solution Data
To view the Solution Data, select the menu item Maxwell > Results > Solution 
Data
Here you can view the Profile and the Convergence.  Note: The default view is for 
convergence is Table.  Select the Plot radio button to view a graphical 
representations of the convergence data.
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Observe the Inductance Matrix
Maxwell > Results> Solution Data…
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Plot Flux Density on Core Cross section
To plot the flux density on the core cross section, a new coordinate system is needed.

Here are the steps to create:

3D Modeler>Coordinate System>Create>Relative CS>Offset

Using the coordinate entry field, enter the position of the new coordinates:

X: 0, Y: 0, Z: 5, Press the Enter key

The name of new Coordinate is RelativeCS1

Select the plot plane: Planes>RelativeCS1:XY

Right mouse click: Field Overlays > Fields > B> Mag _B.
From the plot, we can see the flux density on core is around 1.86 Telsla. It is close to the 
saturation point of Steel_1010.

If we drive the inductor with much lower current, the operating point will be in the linear area. Then 
the inductance will be much higher than the inductance with operating point close to saturation 
point.
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Create a new project
Right Click on Project MaxwellDesign1> Copy

Click on NonlinearInductance>Paste.

A new project named MaxwellDesign2 is created.

Click Excitations: CurrentBottom, Change Current from 100 A to 1 A.

Click Excitations: CurrentTop, Change Current from 100 A to 1 A.

Right Click on Parameters>Assign>Matrix…

Check CurrentTop and CurrentBottom
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Run the new project and Observe the Inductance Matrix
Click on Analysis>Setup1
Right Click on Setup1: Analyze.
The simulation run and stop.

Maxwell > Results> Solution Data…
We can see the inductance is much higher than the previous simulation.
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Plot Flux Density on Core Cross section
Select the plot plane: Planes>RelativeCS1:XY

Right mouse click: Field Overlays > Fields > B> Mag _B.
From the plot, we can see the flux density on core is around 0.086 Telsla. It is working on the 
linear area of  Steel_1010.
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Switched Reluctance Motor
This example is intended to show you how to create and analyze a
magnetostatic problem with stranded conductors on a Switched Reluctance 
Motor geometry using Magnetostatic solver in the Ansoft Maxwell 3D Design 
Environment.  

Within the Maxwell 3D Design Environment, solid coils can be modeled as 
Stranded Conductors.  There are many advantages to using Stranded 
Conductors when modeling coils that have multiple turns.  The first obvious 
advantage is that a coil with multiple wires, say 2500, can be modeled as a 
single object as opposed to modeling each wire which would be 
impracticable.  Defining a Stranded Conductor means that the current 
density will be uniform throughout the cross section of the conductor. 

The example that will be used to demonstrate how Stranded Conductors are 
implemented in a switched Reluctance Motor.  This switched reluctance 
motor will have four phases and two coils per phase..

Eddy Current Solver: There is no fundamental difference between how 
stranded conductors are treated in the Eddy Current solver as compared to 
the Magnetostatic Solver.  When using the Eddy Current Solver and 
specifying Stranded for the terminal excitation the Eddy Effect is 
automatically turned off. 

Transient Solver: See Example 7.1 for setup instructions for this design.
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Theory – Magnetostatic Solver
When using the Magnetostatic Solver, with a Stranded Current Source, the solver 
assumes the following conditions:

1. The current density is uniformly distributed over the cross section of the 
terminal 

2. The direction of the current is indicated by the arrow as seen on the 
terminal.  Change the direction of the current by clicking on Swap Direction
in the Current Excitation window to reverse the flow.

3. The solver does not know how many turns are represented by the coil, thus 
the value of current that is being applied represents the total ampere-turns.  
For this example, the value 3570 could represent any of the following:

1. 25 amps at 150 turns

2. 5 amps at 750 turns

3. 15 amps at 250 turns

or any such combination that produces a value of 3750 ampere-turns.  The 
ration of amp to turns does not impact the magnetics, although it does 
impact the inductance.  Please refer to the overview for details of the 
inductance calculation.
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Theory – Magnetostatic Solver (Continued)
The ampere-turn value used to define the current source is used to calculate the 
current density which is the initial condition used by the solver according to the 
equation:

Where:   I is the total current in ampere-turns

S is the area of the terminal in m2

is the unit normal direction

is the Current Density vector in A/m2

The path of the current is determined by the conduction path.  Select the menu 
item Maxwell > Excitations > Conduction Paths to view the conduction path, and 
verify that the conduction path is correct.  In this example, if any of the coils 
touched the stator, then this would constitute a separate conduction path since 
the material properties of the stator has a conductivity value 2e6 siemens/meter; 
to solve this problem an insulation boundary will need to be applied to the coils or 
stator; please refer to the overview section for details on insulation boundaries.

Although the Magnetostatic solver uses the current density vector J as the initial 
condition, it does not solve for J directly as part of the output solution matrix.  The 
quantity that the Magnetostatic solver directly calculates is the magnetic field 
intensity H.  From H, the current density J in any conductor is derived by:

HJ ×∇=

∧

= n
S
IJ

∧

n
J
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Ansoft Maxwell Design Environment
The following features of the Ansoft Maxwell Design Environment are used to 
create the models covered in this topic

3D Solid Modeling

User Defined Primitives (UDP): Switched Reluctance Motor

Primitives:  Regular Polyhedron

Surface Operations:  Section 

Boolean Operations: Separate Bodies

Boundaries/Excitations

Current: Stranded

Analysis

Magnetostatic

Results

Field Calculator 

Field Overlays:

Magnitude B
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Getting Started

Launching Maxwell
1. To access Maxwell, click the Microsoft Start button, select Programs, and select 

Ansoft and then Maxwell 11.

Setting Tool Options
To set the tool options:

Note:  In order to follow the steps outlined in this example, verify that the 
following tool options are set : 

1. Select the menu item Tools > Options > Maxwell Options
2. Maxwell Options Window:

1. Click the General Options tab

Use Wizards for data entry when creating new boundaries: 
Checked

Duplicate boundaries with geometry: Checked

2. Click the OK button

3. Select the menu item Tools > Options > 3D Modeler Options.
4. 3D Modeler Options Window:

1. Click the Operation tab

Automatically cover closed polylines: Checked

2. Click the Drawing tab

Edit property of new primitives: Checked

3. Click the OK button
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Opening a New Project
To open a new project:

In an  Ansoft Maxwell window, click the On the Standard toolbar, or 
select the menu item File > New.

From the Project menu, select Insert Maxwell Design.

Set Solution Type
To set the solution type:

Select the menu item Maxwell > Solution Type
Solution Type Window:

Choose Magnetostatic

Click the OK button
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Creating the 3D Model

Set Model Units
To set the units:

1. Select the menu item 3D Modeler > Units
2. Set Model Units:

1. Select Units: mm

2. Click the OK button

Set Default Material
To set the default material:

1. Using the 3D Modeler Materials toolbar, choose Select

2. Select Definition Window:

1. Type iron in the Search by Name field

2. Click the OK button
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Create Rotor
To create the rotor:

1. Select the menu item Draw > User Defined Primitive > Syslib > Rmxprt > 
SRMCore

2. From the Create User Defined Primitive dialog

1. For the value of DiaGap, type: 70, Click the Tab key to accept 

2. For the value of DiaYoke, type: 30, Click the Tab key to accept 

3. For the value of Length, type: 65, Click the Tab key to accept 

4. For the value of Poles, type: 6, Click the Tab key to accept 

5. For the value of ThkYoke, type: 9, Click the Tab key to accept 

6. For the value of Embrace, type: 0.5, Click the Tab key to accept 

7. For the value of EndExt, type: 0, Click the Tab key to accept 

8. For the value of InfoCore, type: 0, Click the Tab key to accept 

9. Click the OK button

To set the name:

1. Select the Attribute tab from the Properties window.

2. For the Value of Name type: Rotor

3. Click the OK button

To fit the view:

1. Select the menu item View > Fit All > Active View. 
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Create Stator and Coils:
To create the Stator and Coils

1. Select the menu item Draw > User Defined Primitive > Syslib > Rmxprt > 
SRMCore

2. From the Create User Defined Primitive dialog
1. For the value of DiaGap, type: 75, Click the Tab key to accept 
2. For the value of DiaYoke, type: 120, Click the Tab key to accept 
3. For the value of Length, type: 65, Click the Tab key to accept 
4. For the value of Poles, type: 8, Click the Tab key to accept 
5. For the value of ThkYoke, type: 9, Click the Tab key to accept 
6. For the value of Embrace, type: 0.5, Click the Tab key to accept 
7. For the value of EndExt, type: 1, Click the Tab key to accept 
8. For the value of InfoCore, type: 1, Click the Tab key to accept 
9. Click the OK button

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Stator
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View. 

Ungroup the Stator and Coils
To separate bodies

1. Select the menu item Edit > Select > By Name
2. Select Object Dialog, 

1. Select the objects named: Stator
2. Click the OK button

3. Select the menu item, 3D Modeler > Boolean > Separate Bodies

Process the Coils:
Select Coils

1. Select the menu item Edit > Select > By Name
2. Select Object Dialog, 

1. Select the objects named: Stator_2, Stator_3, Stator_4, Stator_5, 
Stator_6, Stator_7, Stator_8

2. Click the OK button
Delete Coils

1. Select the menu item Edit > Delete
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Create Terminals
Section Coils

1. Select the menu item Edit > Select > By Name
2. Select Object Dialog, 

1. Select the objects named: Stator_1
2. Click the OK button

Section Object
1. Select the menu item Edit > Surface > Section

1. Section Plane: XY
2. Click the OK button

Separate Bodies
1. Select the menu item Edit > Boolean > Separate Bodies

Delete 
1. Select the menu item Edit > Delete

Section Coils
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog, 

1. Select the objects named: Section1
2. Click the OK button

Assign Excitation
1. Select the menu item Maxwell > Excitations > Assign > Current
2. Current Excitation : General

1. Name: Current1
2. Value: 3750 A
3. Type: Stranded

3. Click the OK button

Verify Duplicate Boundary Option is Set
Section To set the tool options:

1. Select the menu item Tools > Options > Maxwell Options
2. Maxwell Options Window:

1. Click the General Options tab
Duplicate boundaries with geometry: Checked

2. Click the OK button
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Change Properties
Change Properties

1. Select the menu item Maxwell > List
2. Design List Window

1. From the list, select row: Stator_1

2. Click the Properties button

3. Properties Window

1. Name: Coil

2. Material: copper

3. Click the OK button

4. From the list, select row: Section1

5. Click the Properties button

6. Properties Window

1. Name: Terminal

2. Click the OK button

7. Click the Done button

Duplicate Coil and Terminal
To select objects

1. Select the menu item Edit > Select > By Name
2. Select Object Dialog, 

1. Select the objects named: Coil, Terminal

2. Click the OK button

To duplicate the objects:

1. Select the menu item, Edit > Duplicate > Around Axis
2. Duplicate Around Axis Window

1. Axis: Z

2. Angle: 45deg

3. Total Number: 8

4. Click the OK button

3. Click the OK button

Project Tree: Eight Excitations
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Stator

Coil_A1

Coil_B1

Coil_C1
Coil_D1

Coil_A2

Coil_B2

Coil_C2
Coil_D2
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Set Default Material
To set the default material:

1. Using the 3D Modeler Materials toolbar, choose vacuum 

Create Region
To create the region:

1. Select the menu item Draw > Regular Polyhedron
2. Using the coordinate entry fields, enter the center position

X: 0.0, Y: 0.0, Z: -100.0, Press the Enter key

3. Using the coordinate entry fields, enter the radius:

dX: 150.0 dY: 0.0, dZ: 0.0, Press the Enter key

4. Using the coordinate entry fields, enter the height:

dX: 0.0, dY: 0.0, dZ: 200.0, Press the Enter key

Segment Number Window

Number of Segments: 12

Click the OK button

To set the name:

1. Select the Attribute tab from the Properties window.

2. For the Value of Name type: Region

3. Display Wireframe: Checked

4. Click the OK button

To turn off the visibility:

1. Select the menu item View > Hide Selection > Active View
To fit the view:

1. Select the menu item View > Fit All > Active View.  
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Analysis Setup

Creating an Analysis Setup
To create an analysis setup:

1. Select the menu item Maxwell > Analysis Setup > Add Solution Setup
2. Solution Setup Window:

1. Click the General tab:

Percent Error: 10

2. Click the Convergence tab:

Refinement Per Pass: 10 %

3. Click the OK button

Save Project
To save the project:

1. In an  Ansoft Maxwell window, select the menu item File > Save As.

2. From the Save As window, type the Filename: maxwell_ms_relmotor

3. Click the Save button

Analyze

Model Validation
To validate the model:

1. Select the menu item Maxwell > Validation Check
2. Click the Close button

Note: To view any errors or warning messages, use the Message 
Manager.

Analyze
To start the solution process:

1. Select the menu item Maxwell > Analyze All
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Solution Data
To view the Solution Data:

1. Select the menu item Maxwell > Results > Solution Data
To view the Profile:

1. Click the Profile Tab.

To view the Convergence:

1. Click the Convergence Tab

Note: The default view is for convergence is Table.  Select 
the Plot radio button to view a graphical representations of 
the convergence data.

2. Click the Close button
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Field Overlays

Create Field Overlay
To create a field plot:

1. Select stator and rotor

1. Select the menu item Edit > Select > By Name
2. Press and hold the CTRL key and click on stator and rotor

2. Select the menu item Maxwell > Fields > Fields >  B > Mag_B
3. Create Field Plot Window

1. Solution: Setup1 :  LastAdaptive

2. Quantity: Mag_B

3. In Volume: All

4. Plot on Surface Only: Checked

5. Click the Done button
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Calculate Current
To use the field calculator

1. Select the menu item Maxwell > Fields > Calculator

2. Select Quantity: J

3. Select Vector: Scal? > Scalar Z

4. Click the button Geometry

5. Geometry Window

1. Select the radio button Surface

2. From the list select: Terminal

3. Click the OK button

6. Click the ∫ (Integrate) button

7. Click the Eval button

8. Click the Done button to close the calculator
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Realization of an equivalent circuit extraction (ECE) of a 
problem with linear movement.

The Electro Mechanical software package provided by Ansoft enables 
system simulation as well as component simulation. Often, the results 
of an in depth study of a magnetic component are needed in a top
level, system analysis.

With Maxwell, the results of a parametric analysis can be used to 
generated an Equivalent Circuit that will be used into Simplorer. This 
Equivalent Circuit is transmitted under the format of a Look up table 
containing the sweep variables as well as the output variables.

This application note presents the extraction of an equivalent circuit 
of a Linear Actuator. We will vary the air gap of the Armature (with the 
stators) and the Input current in the Coil. The outputs will be the Force 
and the inductance of the Coil. Our component in Simplorer will all 4 
Terminals :

2 Electrical Terminals with the current and the EMF (the 
Inductance of the Coil) as Through and Across quantities. 

2 Mechanical Terminals with the Force and the air gap as 
Through and Across quantities.
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Ansoft Maxwell Design Environment
The following features of the Ansoft Maxwell Design Environment are used to 
create the models covered in this topic:

3D Solid Modeling

Primitives:  Box, Cylinder, Lines

Surface Operations:  Section, Sweep Along Vector, Sweep along 
Path

Boolean Operations: Separate Bodies, Subtract, Duplicate (Mirror)

Design Properties

Parameters: Design Parameters

Boundaries/Excitations

Current: Stranded

Boundary: Insulating

Mesh Operations

Volume: Length Based 

Executive Parameters

Force: Virtual Force

Matrix: Inductance

Output variables

From Executive Parameters

Analysis

Magnetostatic

Optimetrics Analysis 

Parametric Sweep

Distributive Analysis

Results

Solutions Data

Equivalent Circuit Extraction 

From Parametric: Linear Movement
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Overview of the Study:

Getting Started

Launching Maxwell

Setting Tool Options

Opening a new project

Set Solution Type

Creating the 3D Model of a Solenoid 

Set Model Units

Create the Armature 

Create the Stators

Create the Coil

Create the Band

Create the Coil Terminal

Separate the Grouped Terminals

Create the Problem Region

Assign Current Source to the Terminal

Assign Boundaries Conditions

Assign Executive Parameters

Assign Mesh Operations

Solve the Nominal Problem

Create an Analysis Set up

Save the Project

Check the Validity of the Model

Analyze

Solution Data of the Nominal Problem
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Overview of the Study (Continued)

Create Parametric Analysis 

Assign Problem Parameters

Create Output Variables

Create Parametric Analysis Setup 

Solve the Parametric Sweep

Solution Data of the Parametric Sweep

ECE from the Parametric Analysis

Create the circuit in Simplorer

Create the Schematic sheet in Simplorer

Create the graphical Displays in Simplorer

Create a Transient Analysis

Run the Analysis
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Getting Started

Launching Maxwell
1. To access Maxwell, click the Microsoft Start button, select Programs, and select 

Ansoft and then Maxwell 11.

Setting Tool Options
To set the tool options:

Note:  In order to follow the steps outlined in this example, verify that the 
following tool options are set : 

1. Select the menu item Tools > Options > Maxwell Options
2. Maxwell Options Window:

1. Click the General Options tab

Use Wizards for data entry when creating new boundaries: 
Checked

Duplicate boundaries with geometry: Checked

2. Click the OK button

3. Select the menu item Tools > Options > 3D Modeler Options.
4. 3D Modeler Options Window:

1. Click the Operation tab

Automatically cover closed polylines: Checked

2. Click the Drawing tab

Edit property of new primitives: Checked

3. Click the OK button
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Opening a New Project
To open a new project:

1. In an  Maxwell window, click the On the Standard toolbar, or 
select the menu item File > New.

2. Select the menu item Project  > Insert Maxwell Design, or click 
on the    icon

Set Solution Type
Select the menu item:  Maxwell > Solution Type > Magnetostatic, or 
right mouse click on MaxwellDesign1 and select Solution Type …

Creating the 3D Model of a solenoid
The example that will be used to demonstrate how to generate an 
equivalent circuit extraction with Maxwell. Then the importation into 
SIMPLORER of the circuit will be described

Set Model Units
Select the menu item 3D Modeler > Units > Select Units: in (inches)
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Create the Armature: 
The armature is made of a box with a cylinder hole. 
Create the armature . Select the Menu item Draw > Box or click on the      

icon.
1. Using the coordinate entry field, enter the box position

X: 0.469, Y: 0.4305, Z: 0.006, Press the Enter key
2. Using the coordinate entry field, enter the relative size of the box

dX: -0.938, dY: -0.861, dZ: 0.112, Press the Enter key

Note:  To create the box with the GUI, use the mouse to draw the box. 

Note:  In the case of a typo, the modification of the coordinates can be 
made within the box. 
Click on the  created object in the panel on the left representing the object 
tree. Change its name from Box1 to Armature.
Change the Material from vacuum to Steel_1010.
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Create the hole Draw > Cylinder or click on the         icon.

1. Using the coordinate entry field, enter the center of base

X: 0.0, Y: 0.0, Z: 0.012, Press the Enter key

2. Using the coordinate entry field, enter the coordinates of a external point of 
the cylinder base

X: 0.091, Y: 0.0, Z:0.0, Press the Enter key

3. Using the coordinate entry field, enter the height

X: 0.0, Y: 0.0, Z: 0.112, Press the Enter key

Note:  To create the cylinder graphically, use the mouse to draw the
cylinder. 

Select the objects Armature and Cylinder1 from the objects tree (maintain 
the Ctrl key to select both objects).
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Select the menu item 3D Modeler > Boolean > Subtract or click on the

icon.

Make sure to have Armature in the box Blank Parts  and Cylinder1 in the 
box Tool Parts. Use the arrows to exchange the objects if necessary.

Change the Material from vacuum to steel_1010. 

Change the color to purple.
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Create the Stators
The two stators are created using a polyline.

Create the polyline Draw > Line or click on the       icon.

1. Using the coordinate entry field, enter the first point of the line

X: 0.5025, Y: 0.0, Z: 0.0, Press the Enter key

2. Using the coordinate entry field, enter the second point of the line

X: 0.5025, Y: 0.168, Z:0.0, Press the Enter key

3. Using the coordinate entry field, enter the next point of the line

X: 0.5025, Y: 0.168, Z:-0.803, Press the Enter key

4. Using the coordinate entry field, enter the next point of the line

X: 0.5025, Y: 0.324, Z:-0.803, Press the Enter key

5. Using the coordinate entry field, enter the next point of the line

X: 0.5025, Y: 0.324, Z:0.0, Press the Enter key

6. Using the coordinate entry field, enter the next point of the line

X: 0.5025, Y: 0.5, Z:0.0, Press the Enter key

7. Using the coordinate entry field, enter the next point of the line

X: 0.5025, Y: 0.5, Z:-0.98, Press the Enter key

8. Using the coordinate entry field, enter the next point of the line

X: 0.5025, Y: -0.5, Z:-0.98, Press the Enter key

9. Using the coordinate entry field, enter the next point of the line

X: 0.5025, Y: -0.5, Z:0.0, Press the Enter key

10. Using the coordinate entry field, enter the next point of the line

X: 0.5025, Y: -0.324, Z:0.0, Press the Enter key

11. Using the coordinate entry field, enter the next point of the line

X: 0.5025, Y: -0.168, Z:-0.803, Press the Enter key

12. Using the coordinate entry field, enter the next point of the line

X: 0.5025, Y: -0.168, Z:0.0, Press the Enter key

13. Using the coordinate entry field, enter the last point of the line

X: 0.5025, Y: 0.0, Z:0.0, Press the Enter key twice.

Change the name of the polyline from Polyline1 to base and leave the other 
default parameters. 

Note:  If you happen to have an incorrect coordinate, you can modify any entry 
from the model  object tree, Lines > Base > CreatePolyline. 
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Create the Stators (Continued)
This base will be swept along a vector. 
Select the object base from the objects tree.
Select the menu item Draw > Sweep > Along vector

1. Using the coordinate entry field, enter the first point of the vector
X: 0.5025, Y: 0.0, Z:0.0, Press the Enter key

2. Using the coordinate entry field, enter the last point of the vector
X: 0.091, Y: 0.0, Z:0.0, Press the Enter key.

Leave the Draft angle to 0 deg and change Draft type to Natural.

Change the name of the object to stator. Change the Material from vacuum to 
steel_1010 and change the color to dark orange.
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The second stator will be duplicated from Stator .

Select Stator from the objects tree.

Select the menu item Edit > Duplicate > Mirror or click on the      icon

1. Using the coordinate entry field, enter the anchor point of mirror plane

X: 0.0, Y: 0.0, Z:0.0, Press the Enter key

2. Using the coordinate entry field, enter the target point of vector normal to 
the mirror plane

X: -0.6, Y: 0.0, Z:0.0, Press the Enter key

After the operation, a window appears and recall the coordinates.

A new object Stator_1 has been created with the same material property and the 
same color as Stator .
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Create the Coil:
The coil is created using a base surface and sweeping the surface along a path.
Create the polyline Draw > Line or click on the       icon.

1. Using the coordinate entry field, enter the first point of the line
X: 0.5025, Y: 0.168, Z: -0.803, Press the Enter key

2. Using the coordinate entry field, enter the second point of the line
X: 0.5025, Y: 0.264, Z:-0.803, Press the Enter key

3. Using the coordinate entry field, enter the next point of the line
X: 0.5025, Y: 0.264, Z:-0.292, Press the Enter key

4. Using the coordinate entry field, enter the next point of the line
X: 0.5025, Y: 0.168, Z:-0.292, Press the Enter key

5. Using the coordinate entry field, enter the last point of the line
X: 0.5025, Y: 0.168, Z:-0.803, Press the Enter key twice

Change the name of the polyline from Polyline1 to Basecoil and leave the other 
default parameters. 
Note:  If you happen to have an incorrect coordinate, you can modify any entry 
from the model’s Lines tree, Lines > Basecoil > CreatePolyline. 
Create the path Draw > Line or click on the       icon.

1. Using the coordinate entry field, enter the first point of the line
X: 0.5025, Y: 0.168, Z: -0.292, Press the Enter key

2. Using the coordinate entry field, enter the second point of the line
X: -0.5025, Y: 0.168, Z: -0.292, Press the Enter key

3. Using the coordinate entry field, enter the next point of the line
X: -0.55, Y: 0.168, Z: -0.292, Press the Enter key

4. Using the coordinate entry field, enter the next point of the line
X: -0.55, Y: -0.168, Z: -0.292, Press the Enter key

5. Using the coordinate entry field, enter the next point of the line
X: -0.5025, Y: -0.168, Z: -0.292, Press the Enter key

6. Using the coordinate entry field, enter the next point of the line
X: 0.5025, Y: -0.168, Z: -0.292, Press the Enter key

7. Using the coordinate entry field, enter the next point of the line
X: 0.55, Y: -0.168, Z: -0.292, Press the Enter key

8. Using the coordinate entry field, enter the next point of the line
X: 0.55, Y: 0.168, Z: -0.292, Press the Enter key

9. Using the coordinate entry field, enter thenext point of the line
X: 0.5025, Y: 0.168, Z:-0.292, Press the Enter key 
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10.    Using the coordinate entry field, enter the last point of the line

X: 0.5025, Y: 0.168, Z:-0.803, Press the Enter key twice

Change the name of the polyline from Polyline1 to path and leave the other 
default parameters.

Select the objects Basecoil and path  from the objects tree.

Select the menu item Draw > Sweep > Along Path. Leave Twist Angle and Draft 
Angle to 0. Make sure Draft type is selected to Natural.

Rename the object to Coil and assign Copper as material. Change the color in 
blue.
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Create the Band
In our study, the Armature will be moved up and down along the Z axis. It is 
always a good idea to help the mesh creation by creating an air box object 
around a object that will be moved (even if the project will be performed with the  
Magnetostatic solver).

Create the air object Draw > Box or click on the       icon. Use the values below 
for the base coordinates and the size of the box.

Change the name of the object to Band. Also, change the Transparency from 0 to 
1; this will keep the Region object displayed as a wire frame.  Keep the material 
as vacuum.
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Create the Coil Terminal
A coil terminal needs to be created in order to assign the current excitation.

Select Coil from the objects tree.

Select the menu item 3D Modeler > Surface > Section > YZ Plane .

Separate the Grouped Terminals
The result of the Surface > Section command, yields two terminals that are 
united.  Since only one terminal is needed, the other terminal needs to be 
deleted, but first they need to be separated.

Select the sheet object:

Select the menu item 3D Modeler > Boolean > Separate Bodies
There are now 2 separate terminals. Delete the second terminal and rename the 
remaining object to Terminal.
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Create the Problem Region
One of the main differences between Maxwell V10 and V11 is that a Background 
Region is not automatically created when a project is started.  A separate object 
needs to be specifically created.

Create the region Draw > Region or select the       icon

The Padding determines how far will the limits of the region be from the objects. 
In this case, select 100 as Padding Percentage to have plenty of room around the 
solenoid. 

WWW.MOHANDESYAR.COM

http://mohandesyar.com/


Ansoft Maxwell 3D Field Simulator  v11 User’s Guide 

5.4
Topic – ECE: Linear movement

5.4-154

Assign Current Source to the Terminal
Select the coil Terminal by using your mouse or selecting from tree on the left 
hand side of the GUI.

Select the menu item Maxwell > Excitations > Assign > Current 
1. Change the Base Name to Current

2. Change the value to 576 Amps

3. Change the type to Stranded

Assign Boundaries Conditions
We assume that no current goes through the stators.
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Assign Boundaries Conditions (Continued)
Select the two stators by holding down the CTRL key and using your mouse or 
selecting from tree on the left hand side of the GUI.

Select the menu item Maxwell > Excitations > Assign > Insulating. Leave the 
default name Insulating1 et select OK.

Assign Executive Parameters 
The force applied on the armature as well as the self inductance of the coil are 
needed . These outputs will be used during the Equivalent Circuit Extraction 
process.

Select the Armature from the objects tree or by using the mouse.

Select the menu item Maxwell > Parameters > Assign > Force

Select Virtual and leave the default name. Make sure the Reference is set to 
Global.

Note:  with Maxwell 11, The Virtual and the Lorentz force are available.  The 
virtual force, based on the Virtual Work Principle is more general and more 
accurate. The force computation is very mesh dependent, so a fine mesh is 
advisable whenever the Force is needed.

The inductance computation leads to an Inductance Matrix (size NxN, with N the 
number of selected conductors), where the M(i,i) entry corresponds to the self 
inductance of the ith conductor and the M(i,j) = M(j,i) entries correspond to the 
mutual inductance terms. In our case, we only have one conductor, therefore we 
will only obtain the self inductance of the Coil (in a 1 by 1 matrix).
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Assign Executive Parameters (Continued)
Select the menu item Maxwell > Parameters > Assign > Matrix
Include the term current in the matrix computation (see below).

Assign Mesh Operations
As mentioned in the previous section, the Force computation is very mesh 
sensitive. Therefore, to save some time computation, we will use a mesh 
operation. 

Select the two stators, the Band object, the Coil, the Armature by holding down 
the CTRL key and using your mouse or selecting from tree on the left hand side 
of the GUI. Do not select the Region.

Select the menu item Maxwell > Mesh Operations > Assign > Inside Selection > 
Length Based

WWW.MOHANDESYAR.COM

http://mohandesyar.com/


Ansoft Maxwell 3D Field Simulator  v11 User’s Guide 

5.4
Topic – ECE: Linear movement

5.4-157

Assign Mesh Operations (Continued)
The addition of 25 000 elements will be enough to achieve a reasonable 
accuracy. We deselect the Restrict Length of Elements and put 25 000 as the 
Maximum number of Elements.

Solve the Nominal Problem

Create an Analysis Set up
Before performing a parametric sweep on the current and the air gap, the 
nominal problem needs to be solved: it is always a good idea to verify that the 
problem is  correctly set.
Note: A solved project is required if output variables that will serve as entries in 
the Parametric table have been created in the Calculator. 
Select the menu item Maxwell > Analysis Setup > Add Solution Setup.
Select General and change the Percent Error from 1to .7. Change the number of 
passes to 5. Leave the bottom of the window unchanged. This way, the Force 
and the Inductance Matrix will be calculated as we expect: the default 
configuration make Maxwell solve for the executive parameters after the last 
adaptive pass (see next page).
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Create an Analysis Set up (Continued)
Select Convergence and change the Refinement Per Pass from 30 to 15 
because we do not need to increase the size of the mesh too much after each 
pass.

Save the Project
Select the menu item File > Save As

From the Save As window, type in Solenoid.

Click on the Save button.
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Check the Validity of the Model
Select the menu item Maxwell > Validation Check, or click on the        icon.

The problem will not solve unless each object has a check mark.

Analyze 
Select the menu item Maxwell > Analyze, or click on the        icon.

The progress bar shows the different stages of the ongoing computation.

Solution Data of the nominal problem
To view the Solution Data, select the menu item Maxwell > Results > Solution 
Data. You have access from this window to the inductance and to the force 
computed as well as other information:

Select the Solution tab: the inductance is available by choosing Matrix1 in 
the pull-down menu. In this case the inductance matrix has only one entry.
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Solution Data of the nominal problem (Continued)
Select the Solution tab: the force values are available by choosing Force1 
in the pull down menu. We have access to the X,Y, and Z components of 
the Force as well as its magnitude. As expected, the Z component of the 
Force is much more larger than the other components.

Select the Convergence tab: the log of the different adaptive passes is 
displayed with the successive sizes of the mesh.

Select the Profile tab: you can find information about the CPU time, the size 
of the generated data.

Select the Mesh Statistics: all the details about the final mesh are 
presented for each of the problem’s region.

Note: you can calculate any quantity using the calculator of Maxwell. Select the 
Menu item Maxwell > Results > Calculator or click on the         icon.

Create Parametric Analysis
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Assign Problem Parameters 
Once the nominal problem has been successfully solved, some parameters need 
to be declared to perform a parametric sweep. We are interested in the 
inductance and the force computed in respect to the input current and the air gap 
between the Armature and the Stator, therefore, we create two parameters: the 
air gap and the input current. In Maxwell 11, any input can be set as parameter. 

Warning: When assigning problem parameters, the solution is invalidated. The 
nominal problem has to be copied if the results are needed. Also, the variables 
created in the calculator that will be used in the parametric sweep must be 
declared before the parameter declaration.

We begin with the current source. From the model tree on the left hand side of 
the GUI, expand the Excitations title and double click on the Current entry. In the 
value case, change  from 576 to amp_turns.

A window pops up asking for the value of amp_turns. Leave it to 576 Amps. 
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Assign Problem Parameters (Continued)
To enter the air gap parameter, expand from the objects tree the Armature entry. 
Double click on CreateBox object.

Change the Z- position of the corner with the parameter armature_init. 

Set the value of armature_ini as .006in + gap. Set gap as 0.0in for the time being.

At any time you can access at the list of the problem parameters. Select the 
menu item Maxwell > Design Properties. The window should look like:
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Create Output Variables
For a parametric analysis, we are only interested in a limited number of output 
parameters. Our goal is to generate an equivalent circuit extraction, therefore we 
want to have for each row the inductance and the output force. If needed, 
Maxwell enables you to save the solution fields for every design of a parametric 
sweep.

Select the menu item Maxwell > Results > Output Variables. From this window, 
we assign output variables.

To create the output variable corresponding to the magnitude of the virtual force 
(Fm), follow the steps below:

1- Select the 

Executive 

parameter

2- Select the Quantity

3- We do not need 

to apply any function to

the Quantity

4- Insert the Quantity 

5- The Expression is set

6- Name the expression and 
Add to the list
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Create Output Variables (Continued)
Proceed the same way to declare Fx, Fy, Fz the components of the Force applied 
to the Armature.

We also declare the inductance as an output variable. Follow a similar procedure, 
but select  Matrix1 from the pull-down menu (see below). Lcc stands for the 
inductance of the coil.

Finally, you should have 5 output variables declared: Fm, Fx, Fy, Fz and Lcc.
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Create Parametric Analysis
Note: The module Optimetrics must be installed in order to be able to run a 
parametric sweep.

Select the Menu item Maxwell > Optimetrics Analysis > Add Parametric. The 
Setup Sweep Analysis pops up. We add the different variables for each 
parameter that will be included in the sweep. Select Add (see Below).

From the Add/Edit Sweep window, select gap in the pull down menu. The air gap 
will linearly vary from 0.0in  to 0.006in with a 0.001in Step. Enter these values in 
the corresponding boxes. Click Add to proceed. 
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Create Parametric Analysis (Continued)
Select amp_turns from the Pull down menu. We sweep this variable with 4 single 
values: -1 A, 330A, 661A and 992 A. Click on the Single Value box, enter the 
actual value and click Add for the 4 different values. Do you forget to press Add 
each time. Close the Window.

The Setup Sweep Analysis window has the following definitions:
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Create Parametric Analysis (Continued)
From the ‘Table’ tab, the 24 variations are displayed.

Leave ‘General’ tab of Setup Sweep Definition unchanged and select the 
‘Calculations’ tab. From this tab, we will define the output variables to include in 
the sweep.

5 output variables are to be included. Click 5 times to the Add button. On the first 
line, from the pull down menu on the left, select Setup: Matrix1, then from the pull 
down menu on the right, select Lcc. On the second line select Setup: Force1 , 
then select  Fm. Repeat the procedure for the other force variables: Fx, Fy, Fz.

In the ‘Options’ tab, leave everything unchecked.

The parametric sweep is set up . 

Note: the number of adaptive passes, the target error and all the analysis 
parameters of the nominal problem will be used. If you happen to have several 
analysis setups, select the setup to use in the ‘General’ tab.
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Solve the Parametric Sweep
Right click on  the ParametricSetup from the Design tree and run the analysis.

Maxwell will start an separated analysis for every row of the table. 

If you have a Distributive Analysis license, you can run the parametric sweep on 
up to 10 machines per Distributive Analysis license. Use the  Distributive 
Analysis button in this case. 

Note: If you cannot click on the Distributive Analysis button, it means that the list 
of machines you want to use is not correctly set. Select the menu item Tool > 
Options > General Options. Go to the Distributed Analysis Options tab. Make 
sure you have at least two machines in the Machine for Distributed Analysis box. 
The local machine (the machine where Maxwell has been running) is not included 
by default. Also, for a two processor machine, you can enter the machine’s name 
twice.
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Solution Data of the Parametric Sweep
Once the analysis is completed, Select the Menu item Maxwell > Optimetrics 
Analysis > Optimetrics Results.

Make sure to select the correct optimetrics setup from the pull down menu, then 
select the Table radio button to view the results table.
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ECE from the Parametric Analysis
Select the menu item Maxwell > Equivalent Circuit Extraction > From Parametric 
Solutions.

Maxwell fills the ECE window with some parameters that correspond to the 
project:

Make sure that the Model type is set to Linear Motion.

Leave the scaling factor to 1 (this factor is used for models with symmetry). 

Choose the Parametric Setup corresponding to your analysis with the 
according solution Setup, Matrix Setup and Force Setup. 

Only the Z component of the force will be used. 

Amperes-Turns have been entered in the model (we selected Stranded 
Conductor): select the corresponding radio button. 

Click on Next to continue.
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ECE from the Parametric Analysis (Continued)
The next window enables you to select or deselect the entries from the 
parametric tables. 

Fm, Fx and Fy computations will not be used in Simplorer. From the pull-down 
menu in the I/O column, select Unused.  We leave the other parameters to their 
default values.

Make sure that the data types are correct. gap defines a Position, amp_turns a 
current.

Click on Next to continue.
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ECE from the Parametric Analysis (Continued)
This window defines the Terminals of the conservative nodes in Simplorer. The 
conservative nodes will have their Across and Through quantities solved by 
Simplorer, ensuring the physical meaning of the simulation.

The Flux (and therefore the EMF) is the electrical Across quantity in this case. 
The current is the Through quantity.

In the Mechanical domain, gap is the Across quantity whereas Force1  is the 
Through quantity.

Maxwell has defined the correct values for the Terminals. Click on Finish.
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ECE from the Parametric Analysis (Continued)
Give a File name and save the output file. 

Maxwell creates the SML file containing the model of the component to be used 
in Simplorer. SML stands for Simplorer Modeling Language, the internal 
language of Simplorer. This script file will be imported into Simplorer.

To improve visibility of the component in Simplorer, it is advised to capture the 
image of the Maxwell 3D design. Select the menu item Edit > Copy To Clipboard. 
You can paste this image in any software (like Paint, …)and save it under a bmp 
format. 

Create the circuit in Simplorer
Note: The software package Simplorer 7 must be installed in order to be able to 
continue.

Open Simplorer version 7, create a project then a Schematic.

From the ModelAgent bar, Select the AddOns tab, then click on interfaces in the 
folder. Right click on ECE Link and select Copy.
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Create the Component in Simplorer (Continued)
Select the tab Users (or the Project tab is some libraries have been created in the 
Project). Select user and select the menu item Edit > Paste. The ECE component 
has been copied to your user section. It is now possible to change the name of 
the component  and to modify the component symbol.

Right click after having selecting the ECE link component. Choose properties. In 
the window, select the General tab and give the component name ECE Solenoid.  
Leave the other parameters to their default values and Select OK.

Right click and select Edit Symbol. From this window, you can draw your own 
symbol or import it from a bmp image (Select the menu item Draw > Insert 
Bitmap).
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Create the Component in Simplorer (Continued)
Drag and drop the ECE Solenoid component on the sheet. Open the component 
dialogue box. Click on the Load model button. 

Browse your disk to recover the output file generated by Maxwell. This file has 
the extension SML.

Click on OK. The model is loaded.
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Create the Component in Simplorer (Continued)
In the component dialogue box, select the Output/Display tab. In the Pin column, 
4 boxes are checked: Current_N1, Current_N2, Force1_N1, Force1_N2. These 
terminals correspond to the electrical and mechanical terminals we defined 
during the ECE process in Maxwell. Verify that in the Show column, the Name at 
Symbol is chosen to ease the wire connection on the sheet.

As additional input (non conservative node), you can specify the number of turns 
in the Coil (in Maxwell, we just gave the overall value of the current) as well as 
give an additional  resistance corresponding to the coil in the Solenoid. 

The component is ready to be used in a Simplorer project.
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Create the Schematic sheet in Simplorer

In this application, the system surrounding the actuator has an 
electric part and a mechanical part. 

For the electrical part, the following components have been dragged 
on the sheet:

A Voltage source E1, with the following parameters:

A resistance R1, with R= 215 mΩ
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Create the Schematic sheet in Simplorer (Continued)
For the electrical part, the following components have been dragged on the 
sheet:

A Force-meter FM1 to measure the actual force coming from the actuator

A Force Source F_initial corresponding to the initial force with F=125 N

A mass MASS that describes the mass of the plunger of the actuator:

A Limit stop LIMIT that represents a parallel damper and spring 
combination:  
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Create the Schematic sheet in Simplorer (Continued)
The mechanical ground and the electrical ground must be included.

Create the graphical Displays in Simplorer
We want to display the Coil Current, the Actuator Force and the Stoke for this 
system.

Drag a 2D view element (from the Displays tab).

Select the yellow button to add the the current of the ECE component. 

1- Click to add a quantity in 
the display 2- Select ECELink1.ICurrent
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Create the graphical Displays in Simplorer
Repeat this operation with 2 new 2D view elements. Add the two following 
quantities:

The force of the plunger: ECELink1.Fz_OUT

The stroke : 39.79 * MASS.S

Create a Transient Analysis
Select the menu item Simulation > Parameters

Fill the window with these parameters:
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Run the Analysis
The simulation can be started by selecting the menu item Simulation > Start

The 2D displays look like:

0

80.00

50.00

0 5.00m2.00m

Coil Curren
    ECELink1.ICurrent [A]

-252.00

-120.00m

-200.00

-100.00

0 5.00m2.00m 4.00m

Actuator Force

    ECELink1.Fz_OUT [V]

0

10.00m

5.00m

0 5.00m2.00m

Stroke
    39.79 * MASS.S [m]
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The implementation and application of Nonlinear Anisotropic 
Material when using the Magnetostatic, and Transient Solvers

In v11 of Maxwell 3D a new function of Nonlinear Anisotropic Material can be 
used  with the Magnetostatic, and Transient Solvers for simulating soft 
magnetic materials. The obvious advantage is significance because 

Non-linear lamination is extensively used in low frequency 
electromagnetic devices for having high induction but with significant 
reduction of eddy current loss in the rolling direction.

Non-linear anisotropy is widely used magnetization, magnetic 
recording, power transformers and large size electrical machines. 
Oriented materials will have higher magnetic field like magnetic flux 
density in special directions as users want but lower magnetic field in 
other directions. 

In this note a magnetostatic model as one step of magnetization will be 
introduced including how to set up Non-linear lamination and Non-linear 
anisotropic materials. Same set up will be used for Transient model. 
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Ansoft Maxwell Design Environment
The following features of the Ansoft Maxwell Design Environment are used to 
create the models covered in this topic

3D Solid Modeling

User Defined Primitives (UDP): RMxprt/SlotCore

Primitives:  Regular Polyhedron Box Cylinder

Surface Operations:  Section Edge Filet

Boolean Operations: Split Separate Bodies

Boundaries/Excitations

Current: Stranded

Windings

Analysis

Magnetostatic

(Transient)

Results

Field Calculator

Group objects with Objectlist

2d plot with Create Report 

Field Overlays:

Flux Density Plots 

WWW.MOHANDESYAR.COM

http://mohandesyar.com/


Ansoft Maxwell 3D Field Simulator  v11 User’s Guide 

5.5
Topic – Anisotropic Material

5.5-184

Getting Started

Launching Maxwell
1. To access Maxwell, click the Microsoft Start button, select Programs, and select 

Ansoft and then Maxwell 11.

Setting Tool Options
To set the tool options:

Note:  In order to follow the steps outlined in this example, verify that the 
following tool options are set : 

1. Select the menu item Tools > Options > Maxwell Options
2. Maxwell Options Window:

1. Click the General Options tab

Use Wizards for data entry when creating new boundaries: 
Checked

Duplicate boundaries with geometry: Checked

2. Click the OK button

3. Select the menu item Tools > Options > 3D Modeler Options.
4. 3D Modeler Options Window:

1. Click the Operation tab

Automatically cover closed polylines: Checked

2. Click the Display tab

Default transparency = 0.8

3. Click the Drawing tab

Edit property of new primitives: Checked

4. Click the OK button
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Opening a New Project
To open a new project:

1. In an  Maxwell window, click the On the Standard toolbar, or select the 
menu item File > New.

2. Select the menu item Project  > Insert Maxwell Design, or click on the    
icon

Set Solution Type
Select the menu item:  Maxwell > Solution Type > Magnetostatic, or right mouse 
click on MaxwellDesign1 and select Solution Type …

Creating the 3D Model of a magnetization model of a four- poles 
out-rotor

The example that will be used to demonstrate how the anisotropic non-linear 
material & non-linear lamination are implemented in a Magnetization model of a 
four-poles out-rotor. The intent of this write up is not how to simulate the out-
rotor motors, it is rather to demonstrate how anisotropic materials are 
implemented within the Magnetostatic (or Transient) solver.  This magnet ring is 
an non-linear anisotropic one (nonlinear in R & Z direction with low permeability 
in Theta direction) and the field core is a laminated one.（lamination direction is 
Global X) Thus we can show how these materials can be set up for create an 
four poles out-rotor.

Set Model Units
Select the menu item 3D Modeler > Units > Select Units: mm (millimeters)
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Create the problem Region
One of the main differences between Maxwell V10 and V11 is that a Background Region is 
not automatically created when a project is started.  A separate object needs to be specifically 
created.

Create a Box region by selecting the menu item Draw > Box  or click on the           icon.

1. Using the coordinate entry field, enter the box position

X: -50, Y: -50, Z: -50, Press the Enter key

2. Then enter the opposite corner for the base rectangle with the height

X: 100.0, Y: 100.0, Z: 100.0, Press the Enter key

Click OK to finish it. Change the name from Box1 to Region by editing the Attribute panal on 
the left hand side of the interface. Keep the material as vacuum.
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Create the Field Core: 
A User Defined Primitive will be used to create the Field Core

Draw > User Defined Primitive > Syslib > Rmxprt > SlotCore
Use the values given in the panel below to create the rotor

Click  SlotCore1 with right of mouse in History Tree Edit >Arrange >Rotate >Y >90
degree>OK 
Click on the just created object in the drawing window and in the panel on the left change its 
name from SlotCore1 to FieldCore

Create material Press of non-linear laminate one for FieldCore
Click Material vacuum to get in the Material Select Definition window, Pick Add Material…
Change name Material1 to Press
Pick Type of Relative Permeability and change it from Simple to Nonlinear, Pick BH curve in 
the right of it, then click Import from file…, select Press.bh for it with OK to finish it.

Pick Solid in Composition Line and Change it to Lamination
Change the Value of –Stacking Factor to 0.95 and keep the Stacking Direction as V(1) (X 
direction). Pick Validate Material , the green tick will be appeared. Click OK to exit.
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Select OK in Select Definition window, Then change SlotCore1 as FieldCore, make sure the 
Material is Press and the Orientation is Global.

Create the Housing and Magnet Ring of Out-rotor:
Create Housing

Draw > RegularPolyhedron then using the coordinate entry field, enter the center position

X: -15.3, Y: 0, Z: 0, Press the Enter key

Then enter the height and the radio

dZ: 24.4 for radius, Press the Enter key

dX: 30.8 for height, Press the Enter key

Number of segments = 36, OK

Change the name from RegularPolyhedron1

to Housing

Draw > RegularPolyhedron then using the coordinate entry field, enter the center position

X: -14.5, Y: 0, Z: 0, Press the Enter key

Then enter the height and the radio

dZ: 22.8 for radius, Press the Enter key

dX: 30.8 for height, Press the Enter key

Number of segments = 72, OK

Change the name from RegularPolyhedron1

to Housing1

Pick Housing and Housing1 in History Tree, Use right mouse Edit > Boolean > Subtract to 
create new Housing
Draw > RegularPolyhedron then using the coordinate entry field, enter the center position

X: -15.3, Y: 0, Z: 0, Press the Enter key

Then enter the height and the radio

dZ: 3.25 for radius, Press the Enter key

dX: -1.7 for height, Press the Enter key

Number of segments = 16, OK

Change the name from RegularPolyhedron1 

to Housing2
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Pick Housing and Housing2 in History Tree, Use right mouse Edit > Boolean > Unit to 
create new Housing

Draw > RegularPolyhedron then using the coordinate entry field, enter the center position

X: 0, Y: 0, Z: 0, Press the Enter key

Then enter the height and the radio

dZ: 2.45 for radius, Press the Enter key

dX: -20 for height, Press the Enter key

Number of segments = 16, OK

Change the name from RegularPolyhedron1

to Housing3

Pick Housing and Housing3 in History Tree, Use right mouse Edit > Boolean > Substract to 
create final Housing

Create material Press1 of non-linear one for Housing
Click Housing in History Tree, then pick Material vacuum in it’s Attribute to get in the 
Material Select Definition window, Search & pick Press
Select Clone Materials 
Pick Lamination in Composition Line and Change it to Solid
Click OK to exit. Press1 will be appeared in Material Name Listing

Click OK to exit Select Definition. Make sure Press1 will be the Material of Housing
and change the color as light blue

Create Magnet Ring named as Mag
Draw > RegularPolyhedron then using the coordinate entry field, enter the center position

X: -10, Y: 0, Z: 0, Press the Enter key

Then enter the height and the radio

dZ: 22.8 for radius, Press the Enter key

dX: 20 for height, Press the Enter key

Number of segments = 72, OK

Change the name from RegularPolyhedron1

to Mag
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Draw > RegularPolyhedron then using the coordinate entry field, enter the center position

X: -10, Y: 0, Z: 0, Press the Enter key

Then enter the height and the radio

dZ: 18.8 for radius, Press the Enter key

dX: 20 for height, Press the Enter key

Number of segments = 72, OK

Change the name from RegularPolyhedron1

to Mag1
Pick Mag and Mag1 in History Tree, Use right mouse Edit > Boolean > Substract to create 
final Mag

Create material Mag_aniso of non-linear anisotropic one for Mag
Click Mag in History Tree, then pick Material vacuum in it’s Attribute to get in the Material 
Select Definition window, Pick Add Material…
Change name Material1 to mag_aniso, and Material Coord. System Cartesian to Cylindrical
Pick Type of Relative Permeability and change it from Simple to Anisotropic

Change Type of T(1,1) from Simple to Nonlinear,  Click BH curve in the right of it, then click 
Import from file…, select Mag.bh for it with OK to finish it.

Change Value of T(2,2) from 0 to 20
Change Type of T(3,3) from Simple to Nonlinear,  Click BH curve in the right of it, then click 
Import from file…, select Mag.bh for it with OK to finish it.

Click Validate Material to get green Tick Mark. OK to exit. mag_aniso will be appeared in 
Material Name Listing

Click OK to exit Select Definition. Make sure mag_aniso will be the Material of Ma

Using 3d Modeler >  Coordinate System > 
Create > Relative CS > Rotated
Select the x axis X:0; Y:1; Z:0 Press Enter

Select the point on xy plane X:0; Y:0; Z:1

Press Enter. Then change Coord Name

From RelativeCS1 to RelativeCS0
Double click Mag in Histery Tree, Change the 

Orientation Value from Global to RelativeCS0 
with OK to exit.

Note: Because in Cylindrical Coordinate System, Theta direction is fixed as T(2,2), the 
Global CS can’t be used for Mag directly. RelativeCS0 must be created for it.
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Create the coils
Create Coil named as coil1

Draw > Box then using the coordinate entry field, enter the box position

X: 14.2, Y: 6.2, Z: -7.8, Press the Enter key

Then enter the length, width and height of the box 

dX: -28.2; dY: 6.5; dZ: 15.6, Press the Enter key

Box1 will be created.

Draw >Box then using the coordinate entry field, enter the box position

X: 11.2, Y: 6.2, Z: -4.8, Press the Enter key

Then enter the length, width and height of the box 

dX: -22.4; dY: 6.5; dZ: 9.6, Press the Enter key

Box2 will be created.

Pick Box1 & Box2, Using right mouse

Edit > Boolean > Substract to create final Box1
Change the name of Box1 to Coli_1 and set 

material Cupper  for it

Select Coli_1 in History Tree, Using right mouse Edit > Arrange > Rotate 
select X as rotating Axis with 45 degree, OK to finish it.

View > Active View Visibility to erase the tick marks for all except Coil_1 as below:

Change                        in Tool Bar to                    

pick 4 edges of the Coil_1 as below:

Select the icon        of Fillet the selected edges 

in Tool Bar and set 2 mm as Fillet Radius

After OK to finished Coil_1, change the color of

it as dark yellow.
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Using Alt Key and double click the mouse on the 

the coordinate (0,0,0) to rotate the View 

as YZ plane (See right)

Using 3d Modeler >  Coordinate System > 
Create > Relative CS > Offiset, 
input X: 0; Y: 0.2; Z: 0.2 with Enter key

the coordinate CS1 will be created.

Pick Coil_1 in History Tree, Use right mouse 

Edit > Boolean > Split and select XY plane

with OK

Pick Coil_1 in History Tree, Use right mouse 

Edit > Boolean > Split and select XZ plane

with OK. The final Coil1 will be finished.

Select Global coordinate in History Tree 

Pick Coil_1 in History Tree, Use right mouse 

Edit > Duplicate > Around Axis 
Select X Axis with Angle 90 & Total Number 4

All 4 coils will be finished

Pick all Coil_1- 4 in History Tree, Use right 

mouse Edit > Surface > Section and  select YZ 
plane with OK 

Pick all Section1- 4 in History Tree, Use right  mouse Edit > Boolean > Separate Bodies
Pick Section1_1,2_1,3_1,4_1, then Click Delete Key.

Now the whole model will be as below:

Housing

Mag

Coils

FieldCore
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Assign Current Source to the Terminals
Select Coil Terminals Section1 & Section3 by using holding down the CTRL key 
and using your mouse or selecting from tree on the left hand side of the GUI

Select the menu item Maxwell > Excitations > Assign > Current 
1. Change the Base Name to Current13

2. Change the value to 4000 Amps

3. Change the type to Stranded

Select Coil Terminals Section2 & 

Section4

Select the menu item Maxwell > 
Excitations > Assign > Current 

1. Change the Name to Current24

2. Change the value to 4000 Amps

3. Change the type to Stranded

4. Pick Swap Direction

The project tree now shows 4 separate Excitations:

Any one of them can be selected to check the 

directions of the Excitation Current.
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Theory of the Nonlinear Anisotropic Material for soft 
magnetic materials

Basic ideas for new nonlinear anisotropic materials:
The cross effects of the magnetic field in the different principle directions 
are decoupled by introducing an equivalent magnetic field magnitude in 
each principle direction based on an anisotropic characterization of the 
energy density . 

Only B-H curves in the principal directions of the materials – two curves in 
2D or three curves in 3D – need to be measured 

The anisotropic behavior of laminations with either isotropic or anisotropic 
steel is also considered. 

Proposed approach

Since applying the same value of H in different principle directions will 
cause different level of magnetic saturations, the approach refers all 
components of H to each principle direction by referring factor k to 
determine the saturation in that direction 

where       is introduced to consider lamination effects and kxy is determined 
by magnetic energy density w in x and y principle directions, kxy = wx /wy,

and similarly to other k’s.

The permeability for each principle direction is obtained in terms of the 
equivalent magnitude He in that direction. For example, for axis x: 
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1

The Modeling Sequence will be as follows:

Reference:

[1] D. Lin, P. Zhou, Z. Badics, W. N. Fu, Q. M. Chen and Z. J. Cendes, “A New Nonlinear 
Anisotropic Model for Soft Magnetic Materials” , CSY0084 of COMPUMAG’2005
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Create an Analysis Setup
Select the menu item Maxwell > Analysis Setup > Add Solution Setup
Select General and change the Percent Error from 1 to 5

Select Convergence and change the Refinement Per Pass from 30 to 20
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Save the Project
Select the menu item File > Save As

From the Save As window, type in GST16

Click on the Save button

Check the Validity of the Model
Select the menu item Maxwell > Validation Check, or click on the        icon

The problem won’t solve unless each object has a check mark.

Analyze 
Select the menu item Maxwell > Analyze, or click on the        icon

The Analysis will be start as below:
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Solution Data
To view the Solution Data, select the menu item Maxwell > Results > 
Solution Data
Here you can view the Profile and the Convergence.  Note: The 
default view is for convergence is Table.  Select the Plot radio button 
to view a graphical representations of the convergence data.
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Plot Flux Density on Cross-section YZ of Mag
To plot the flux density on YZ cut-plane of the magnetic, select the Global YZ of 
Planes in History Tree by clicking on it, and move the mouse to 3d Modeler 
Window then right mouse click and select Fields > B > B _Vector, in Create Field 
Plot Window select B_Vector in “Quantity” and Mag in “In Volume”, Press Done.

The field plot is a little misleading since it show different colors across the YZ 
plane, but the legend displays the exact value for the full color spectrum.  To 
change the scale, double click on the legend and then select Scale.  Select the 
radio button Use Limits and set the Min to 0.0001, the Max to 0.8, click on Apply

Then select Marker/Arrow, in Arrow options Change the Type as Umbrella and 
move Size Arrow to largest, click on Apply.

Then select Plots, in Vector plot Select Uniform and move the Spacing size to 
smallest, set Min. as 0.7 and Max. as 3, click on Apply.
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The plot of the flux density on YZ cut plane of the Mag will be as below:

Note: Please note that if the Mag is not set up as anisotropic one (i.e. uniform 
Nonlinear one) the B field between two magnetic poles will be very large in the 
theta directions, which will be not as good as user wanted.
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Plot Flux Density Bmag on Cross-section YZ of Mag, FieldCore & 
Housing

To plot the Field on more than one objects, the group function is needed. Pick 
Mag, FieldCore & Housing in History Tree, then 3D Modeler/List/Create/Object 
List, then click OK to create Objectlist1

Select the Global YZ of Planes in History Tree and move the mouse to 3d 
Modeler Window then right mouse click and select Fields > B > Mag_B, pick 
Objectlist1 in “In Volume” then press Done
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The plot of the mag_B on YZ cut plane of the Mag, FieldCore & Housing will be 
as below:

User may double click on the legend and change Scale to see the detail field 
distributions  
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Plot Flux Density B_radial on an arc of the Mag
To see the detail distribution near the inner surface of the Mag, the 2d plot on 
a cut-line will be needed. 
Create a cut-line of arc

Draw > Arc > 3 Points and select Yes for Question below:

using the coordinate entry field, Enter first endpoint
X: 0, Y: 19.0, Z: 0, Press the Enter key 

Then enter arc intercept (middle point)
X: 0, Y: 0, Z: 19, Press the Enter key

Enter second endpoint
X: 0, Y: -19.0, Z: 0, Press the Enter key twice. 

Press OK to create Polyline1.
Create B_radial in Calculator 

Select the Global YZ of Planes in History Tree and move the mouse to 
3d Modeler Window then right mouse click and select Maxwell >Fields 
> Calculator 

Function > Scalar Z > OK
Function > Scalar Y > OK
Trig > ATan2 >Push [ATan2(Z,Y) = ATan(Z/Y)]
Trig > Sin > Exch > Trig > Cos
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Quantity > B > Scal? > Scalar Y > * >Exch
Quantity > B > Scal? > Scalar Z > * > + ,the Br for arc is ready.

Pick Add  and type the Name as B_radial , pick Ok to finish it.
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In Maxwell V11 all 2d plot will be created with Create Report
Maxwell > Result >Create Report > OK 

Select Polyline1 in Geometry, pick B_radial in Quantity, click Add Trace
press Done, the result curve on cutline will be se below:
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Chapter 6.0 – Eddy Current Examples
6.1 – Asymmetrical Conductor with a Hole
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The Asymmetrical Conductor with a Hole
This example is intended to show you how to create and analyze an 
Asymmetrical Conductor with a Hole using the Eddy Current solver in the Ansoft 
Maxwell 3D Design Environment.

Stock (Aluminum)

Coil (Copper)
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Getting Started

Launching Ansoft Maxwell
1. To access Ansoft Maxwell, click the Microsoft Start button, select Programs, and 

select the Ansoft > Maxwell 11 program group.  Maxwell 11.

Setting Tool Options
To set the tool options:

Note:  In order to follow the steps outlined in this example, verify that the 
following tool options are set : 

1. Select the menu item Tools > Options > Maxwell Options
2. Maxwell Options Window:

1. Click the General Options tab

Use Wizards for data entry when creating new boundaries: 
Checked

Duplicate boundaries with geometry: Checked

2. Click the OK button

3. Select the menu item Tools > Options > 3D Modeler Options.
4. 3D Modeler Options Window:

1. Click the Operation tab

Automatically cover closed polylines: Checked

2. Click the Drawing tab

Edit property of new primitives: Checked

3. Click the OK button

WWW.MOHANDESYAR.COM

http://mohandesyar.com/


Example (Eddy Current) – Asymmetrical Conductor

6.1

6.1-209Ansoft Maxwell 3D Field Simulator v11 User’s Guide 

Opening a New Project
To open a new project:

In an  Ansoft Maxwell window, click the On the Standard toolbar, or 
select the menu item File > New.

From the Project menu, select Insert Maxwell Design.

Set Solution Type
To set the solution type:

Select the menu item Maxwell > Solution Type
Solution Type Window:

Choose Eddy Current

Click the OK button
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Creating the 3D Model

Set Model Units
To set the units:

1. Select the menu item 3D Modeler > Units
2. Set Model Units:

1. Select Units: mm

2. Click the OK button

Set Default Material
To set the default material:

1. Using the 3D Modeler Materials toolbar, choose Select

2. Select Definition Window:

1. Type aluminum in the Search by Name field

2. Click the OK button

WWW.MOHANDESYAR.COM

http://mohandesyar.com/


Example (Eddy Current) – Asymmetrical Conductor

6.1

6.1-211Ansoft Maxwell 3D Field Simulator v11 User’s Guide 

Create Stock
To create the stock:

1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position

X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: 294.0, dY: 294.0, dZ: 19.0, Press the Enter key

To set the name:

1. Select the Attribute tab from the Properties window.

2. For the Value of Name type: stock

3. Click the OK button

To fit the view:

1. Select the menu item View > Fit All > Active View. 

Create Hole in Stock
To create the hole:

1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position

X: 18.0, Y: 18.0, Z: 0.0, Press the Enter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: 126.0, dY: 126.0, dZ: 19.0, Press the Enter key

To set the name:

1. Select the Attribute tab from the Properties window.

2. For the Value of Name type: hole

3. Click the OK button

To select the objects:

1. Select the menu item Edit > Select All
To complete the stock:

1. Select the menu item 3D Modeler > Boolean > Subtract 
2. Subtract Window

Blank Parts: stock

Tool Parts: hole

Click the OK button
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Set Default Material
1. Using the 3D Modeler Materials toolbar, choose Select

2. Select Definition Window:

1. Type copper in the Search by Name field

2. Click the OK button

Create Coil (Hole) 
To create coil:

1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position

X: 119.0, Y: 25.0, Z: 49.0, Press the Enter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: 150.0, dY: 150.0, dZ: 100.0, Press the Enter key

To set the name:

1. Select the Attribute tab from the Properties window.

2. For the Value of Name type: coil_hole

3. Click the OK button

To create the filets:

1. Select the menu item Edit > Select > Edges. 

2. Using the mouse graphically select the 4 z-directed edges.  Hold down the 
CTRL key to make multiple selections.  

3. Select the menu item 3D Modeler > Fillet
4. Fillet Properties

1. Fillet Radius: 25mm

2. Setback Distance: 0mm

3. Click the OK button

Select 4 Edges
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Create Coil 
To create coil:

1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position

X: 94.0, Y: 0.0, Z: 49.0, Press the Enter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: 200.0, dY: 200.0, dZ: 100.0, Press the Enter key

To set the name:

1. Select the Attribute tab from the Properties window.

2. For the Value of Name type: coil

3. Click the OK button

To create the filets:

1. Select the menu item Edit > Select > Edges. 

2. Using the mouse graphically select the 4 z-directed edges.  Hold down the 
CTRL key to make multiple selections.  

3. Select the menu item 3D Modeler > Fillet
4. Fillet Properties

1. Fillet Radius: 50mm

2. Setback Distance: 0mm

3. Click the OK button

To select the object for subtract

1. Select the menu item Edit > Select > Objects
2. Select the menu item Edit > Select > By Name
3. Select Object Dialog, 

1. Select the objects named: coil, coil_hole

2. Click the OK button

To complete the coil:

1. Select the menu item 3D Modeler > Boolean > Subtract 
2. Subtract Window

Blank Parts: coil

Tool Parts: coil_hole

Click the OK button

To fit the view:

1. Select the menu item View > Fit All > Active View. 
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Create Offset Coordinate System
To create an offset Coordinate System:

1. Select the menu item 3D Modeler > Coordinate System > Create > 
Relative CS > Offset

2. Using the coordinate entry fields, enter the origin

X: 200.0, Y: 100.0, Z: 0.0, Press the Enter key

Create Excitation
Object Selection

1. Select the menu item Edit > Select > By Name
2. Select Object Dialog, 

1. Select the objects named: coil

2. Click the OK button

Section Object

1. Select the menu item Edit > Surface > Section
1. Section Plane: XZ
2. Click the OK button

Separate Bodies

1. Select the menu item Edit > Boolean > Separate Bodies
Assign Excitation

1. Select the menu item Maxwell > Excitations > Assign > Current
2. Current Excitation : General

1. Name: Current1

2. Value: 2742 A

3. Type: Stranded

Note: The current flow should be counter-clockwise when viewing 
the coil from above.  Use the Swap Direction button to change the 
direction.

3. Click the OK button
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Set Eddy Effect
To set the eddy effect for the stock object

1. Select the menu item Maxwell > Excitations > Set Eddy Effects
2. Set Eddy Effect, 

1. Check the settings as shown

2. Click the OK button

Show Conduction Path
Show Conduction Path

1. Select the menu item Maxwell > Excitations > Conduction Paths > Show 
Conduction Paths

2. From the Conduction Path Visualization dialog, select the rows to visualize 
the conduction path in on the 3D Model.

3. Click the Close button

Define a Region 
To define a Region:

1. Select the menu item Draw > Region
1. Padding Date: One

2. Padding Percentage: 300

3. Click the OK button
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Analysis Setup

Creating an Analysis Setup
To create an analysis setup:

1. Select the menu item Maxwell > Analysis Setup > Add Solution Setup
2. Solution Setup Window:

1. Click the General tab:

Percent Error: 2

2. Click the Convergence tab:

Refinement Per Pass: 50 %

3. Click the Solver tab:

Adaptive Frequency: 200 Hz

4. Click the OK button

Save Project
To save the project:

1. In an  Ansoft Maxwell window, select the menu item File > Save As.

2. From the Save As window, type the Filename: maxwell_asymcond

3. Click the Save button

Analyze

Model Validation
To validate the model:

1. Select the menu item Maxwell > Validation Check
2. Click the Close button

Note: To view any errors or warning messages, use the Message 
Manager.

Analyze
To start the solution process:

1. Select the menu item Maxwell > Analyze All
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Create Reports

Create z-component of B-Field (real part) vs. Distance plot on a line
To create a line:

1. Make sure that the Global Coordinate System is selected:

3D Modeler > Coordinate System > Set Working CS

2. Select the menu item Draw > Line
3. When the dialog appears asking to create a non-model object, click the Yes

button.

4. Select the menu item Draw > Line
5. Using the coordinate entry fields, enter the vertex point:

X: 0.0, Y: 72.0, Z: 34.0, Press the Enter key

6. Using the coordinate entry fields, enter the vertex point:

X: 288.0, Y: 72.0, Z: 34.0, Press the Enter key

7. Using the mouse, right-click and select Done

To set the name:

1. Select the Attribute tab from the Properties window.

2. For the Value of Name type: FieldLine

3. Click the OK button
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To calculate real part of the z-component of B-field (use the fields calculator)

1. Select the menu item Maxwell > Fields > Calculator

2. Select Quantity: B

3. Select Vector: Scal? > Scalar Z

4. Select General: Complex > Real

5. Click the Smooth button

6. Click the Number Button

1. Type: Scalar

2. Value: 10000

3. Click the OK button

7. Click the * button

8. Click the Add button

9. Named Expression

1. Name: Bz_real

2. Click the OK button

10. Click the Done button

Create Report
1. Select the menu item Maxwell > Results > Create Report
2. Create Report Window:

1. Report Type: Fields

2. Display Type: Rectangular

3. Click the OK button

3. Traces Window:

1. Solution: Setup1: LastAdaptive

2. Domain: FieldLine

3. Click the Y tab

1. Category: Calculator Expressions

2. Quantity: Bz_real

3. Function: <none>

4. Click the Add Trace button

4. Click the Done button
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Field Overlays

Create Field Overlay
To select an object

Select the menu item Edit > Select > By Name
Select Object Dialog, 

Select the objects named: stock

Click the OK button

To create a field plot:

1. Select the menu item Maxwell > Fields > Fields >  J > Mag_J
2. Create Field Plot Window

1. Solution: Setup1 :  LastAdaptive

2. Quantity: Mag_J

3. In Volume: All

4. Plot on Surface Only: Checked

5. Click the Done button
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Create Field Overlay
To select an object

Select the menu item Edit > Select > By Name
Select Object Dialog, 

Select the objects named: stock

Click the OK button

To create a field plot:

1. Select the menu item Maxwell > Fields > Fields >  J > Vector_J
2. Create Field Plot Window

1. Solution: Setup1 :  LastAdaptive

2. Quantity: Vector_J

3. In Volume: All

4. Plot on Surface Only: Checked

5. Click the Done button

To modify a Magnitude field plot:

1. Select the menu item Maxwell > Fields >  Modify Plot Attributes
2. Select Plot Folder Window:

1. Select: J

2. Click the OK button

3. J Window:

1. Click the Plots tab

1. Plot: Vector_J1

2. Vector Plot

3. Set the Spacing slider to the minimum

2. Click the Marker/Arrow tab

1. Arrow Options

2. Map Size: Unchecked

3. Arrow Tail: Unchecked

4. Use the slider bar to adjust the
size

2. Click the Close button
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Chapter 7.0 – Transient Examples
7.1 – Switched Reluctance Motor (Stranded Conductors)
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Stranded Conductors
This example is intended to show you how to create and analyze a transient 
problem on a Switched Reluctance Motor geometry using the Transient 
solver in the Ansoft Maxwell 3D Design Environment.  

Within the Maxwell 3D Design Environment, solid coils can be modeled as 
Stranded Conductors.  There are many advantages to using Stranded 
Conductors when modeling coils that have multiple turns.  The first obvious 
advantage is that a coil with multiple wires, say 2500, can be modeled as a 
single object as opposed to modeling each wire which would be 
impracticable.  Defining a Stranded Conductor means that the current 
density will be uniform throughout the cross section of the conductor. 

The example that will be used to demonstrate how Stranded Conductors are 
implemented is a switched Reluctance Motor.  This switched reluctance 
motor will have four phases and two coils per phase, thus we can show how 
independent coils can be grouped to create windings.  

Magnetorstatic: See Example 5.3 for setup instructions for this design.
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Theory – Transient Solver
When creating Windings in the Transient solver, it is assumed that all of the coils 
used to make up that winding are connected in series.  

When creating a Winding and using voltage sources, the Winding Panel asks for 
the Initial Current, Resistance, Inductance, and Voltage. 

Initial Current:  This is an initial condition used by the solver

Resistance:  This is the DC resistance of the total winding; for the Phase_A
winding, this is the resistance of Coil_A1 and Coil_A2 in series.

Inductance: This is any extra inductance that is not modeled that needs to
be added.  For example, and additional line inductance or source
inductance.

Voltage: This is the source voltage which can be a constant, function, or 
piecewise linear curve.

A sketch of the Phase_A Winding circuit is: 
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Theory – Transient Solver (Continued)
If the Winding was defined as a Current Source instead of a Voltage Source, the 
only additional field to modify is the initial current.  The circuit would look like this:

The DC Resistance and Extra Inductance is not needed since this is a 
current source and its value is guaranteed regardless of any value for the 
DC Resistance or Extra Inductance.

The third option for the Winding setup is External.  This means that there is an 
external circuit that is made up of arbitrary components.  Please refer to the 
Topic paper on External Circuits for the details on how this is implemented.

Please note that if the two coils that make up the Phase_A winding were 
connected in parallel instead of series, then two separate Windings would need 
to be created. 

In regards to the current density, the Transient solver treats stranded conductors 
the same as in the Magnetostatic solver; that is, the current density is uniform 
across the terminal and the solver calculates the magnetic field intensity H 
directly and the current density vector J indirectly.  

There are two options when defining the type of winding: Solid or Stranded. This 
write up is for Stranded Windings only.  For a full description of how Solid 
windings are implemented, please refer to the Topic paper Solid Conductors.
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Ansoft Maxwell Design Environment
The following features of the Ansoft Maxwell Design Environment are used to 
create the models covered in this topic

3D Solid Modeling

User Defined Primitives (UDP): Switched Reluctance Motor

Primitives:  Regular Polyhedron

Surface Operations:  Section 

Boolean Operations: Separate Bodies

Boundaries/Excitations

Current: Stranded

Analysis

Transient

Results

Field Calculator 

Field Overlays:

Magnitude B
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Getting Started

Launching Maxwell
1. To access Maxwell, click the Microsoft Start button, select Programs, and select 

Ansoft and then Maxwell 11.

Setting Tool Options
To set the tool options:

Note:  In order to follow the steps outlined in this example, verify that the 
following tool options are set : 

1. Select the menu item Tools > Options > Maxwell Options
2. Maxwell Options Window:

1. Click the General Options tab

Use Wizards for data entry when creating new boundaries: 
Checked

Duplicate boundaries with geometry: Checked

2. Click the OK button

3. Select the menu item Tools > Options > 3D Modeler Options.
4. 3D Modeler Options Window:

1. Click the Operation tab

Automatically cover closed polylines: Checked

2. Click the Drawing tab

Edit property of new primitives: Checked

3. Click the OK button
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Opening a New Project
To open a new project:

In an  Ansoft Maxwell window, click the On the Standard toolbar, or 
select the menu item File > New.

From the Project menu, select Insert Maxwell Design.

Set Solution Type
To set the solution type:

Select the menu item Maxwell > Solution Type
Solution Type Window:

Choose Transient

Click the OK button
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Creating the 3D Model

Set Model Units
To set the units:

1. Select the menu item 3D Modeler > Units
2. Set Model Units:

1. Select Units: mm

2. Click the OK button

Set Default Material
To set the default material:

1. Using the 3D Modeler Materials toolbar, choose Select

2. Select Definition Window:

1. Type iron in the Search by Name field

2. Click the OK button
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Create Rotor
To create the rotor:

1. Select the menu item Draw > User Defined Primitive > Syslib > Rmxprt > 
SRMCore

2. From the Create User Defined Primitive dialog

1. For the value of DiaGap, type: 70, Click the Tab key to accept 

2. For the value of DiaYoke, type: 30, Click the Tab key to accept 

3. For the value of Length, type: 65, Click the Tab key to accept 

4. For the value of Poles, type: 6, Click the Tab key to accept 

5. For the value of ThkYoke, type: 9, Click the Tab key to accept 

6. For the value of Embrace, type: 0.5, Click the Tab key to accept 

7. For the value of EndExt, type: 0, Click the Tab key to accept 

8. For the value of InfoCore, type: 0, Click the Tab key to accept 

9. Click the OK button

To set the name:

1. Select the Attribute tab from the Properties window.

2. For the Value of Name type: Rotor

3. Click the OK button

To fit the view:

1. Select the menu item View > Fit All > Active View. 
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Create Stator and Coils:
To create the Stator and Coils

1. Select the menu item Draw > User Defined Primitive > Syslib > Rmxprt > 
SRMCore

2. From the Create User Defined Primitive dialog
1. For the value of DiaGap, type: 75, Click the Tab key to accept 
2. For the value of DiaYoke, type: 120, Click the Tab key to accept 
3. For the value of Length, type: 65, Click the Tab key to accept 
4. For the value of Poles, type: 8, Click the Tab key to accept 
5. For the value of ThkYoke, type: 9, Click the Tab key to accept 
6. For the value of Embrace, type: 0.5, Click the Tab key to accept 
7. For the value of EndExt, type: 1, Click the Tab key to accept 
8. For the value of InfoCore, type: 1, Click the Tab key to accept 
9. Click the OK button

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Stator
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View. 

Ungroup the Stator and Coils
To separate bodies

1. Select the menu item Edit > Select > By Name
2. Select Object Dialog, 

1. Select the objects named: Stator
2. Click the OK button

3. Select the menu item, 3D Modeler > Boolean > Separate Bodies

Process the Coils:
Select Coils

1. Select the menu item Edit > Select > By Name
2. Select Object Dialog, 

1. Select the objects named: Stator_2, Stator_3, Stator_4, Stator_5, 
Stator_6, Stator_7, Stator_8

2. Click the OK button
Delete Coils

1. Select the menu item Edit > Delete
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Create Terminals
Section Coils

1. Select the menu item Edit > Select > By Name
2. Select Object Dialog, 

1. Select the objects named: Stator_1
2. Click the OK button

Section Object
1. Select the menu item Edit > Surface > Section

1. Section Plane: XY
2. Click the OK button

Separate Bodies
1. Select the menu item Edit > Boolean > Separate Bodies

Delete 
1. Select the menu item Edit > Delete

Section Coils
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog, 

1. Select the objects named: Section1
2. Click the OK button

Assign Excitation
1. Select the menu item Maxwell > Excitations > Assign > Coil Terminals
2. Coil Terminal Excitation : General

1. Name: CoilTerminal1
2. Number of Conductors: 150

3. Click the OK button

Verify Duplicate Boundary Option is Set
Section To set the tool options:

1. Select the menu item Maxwell > Options > Maxwell Options
2. Maxwell Options Window:

1. Click the General tab
Duplicate boundaries with geometry: Checked

2. Click the OK button
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Change Properties
Change Properties

1. Select the menu item Maxwell > List
2. Design List Window

1. From the list, select row: Stator_1

2. Click the Properties button

3. Properties Window

1. Name: Coil

2. Material: copper

3. Click the OK button

4. From the list, select row: Section1

5. Click the Properties button

6. Properties Window

1. Name: Terminal

2. Click the OK button

7. Click the Done button

Duplicate Coil and Terminal
To select objects

1. Select the menu item Edit > Select > By Name
2. Select Object Dialog, 

1. Select the objects named: Coil, Terminal

2. Click the OK button

To duplicate the objects:

1. Select the menu item, Edit > Duplicate > Around Axis
2. Duplicate Around Axis Window

1. Axis: Z

2. Angle: 45deg

3. Total Number: 8

4. Click the OK button

3. Click the OK button

Project Tree: Eight Excitations
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Add Windings
To add windings

1. Select the menu item Maxwell > Excitations > Add Winding
2. Winding Window

1. Name: Winding1

2. Type: Voltage

3. Stranded

4. Resistance: 2.5 ohm

5. Voltage: 120 V

6. Click the OK button

3. Repeat these steps three more times to add: Winding2, Winding3, 
Winding4

Assign Terminals to Windings
To select windings

1. Expand the Project tree to display the Excitations

2. Using the mouse, right-click on Winding1 and select Add Terminals

3. Add Terminal Window

1. From the list, select: CoilTerminal1, CoilTerminal5

2. Click the OK button

4. Repeat these steps for:

Winding2

CoilTerminal2

CoilTerminal6

Winding3

CoilTerminal3

CoilTerminal7

Winding2

CoilTerminal4

CoilTerminal8
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Set Default Material
To set the default material:

1. Using the 3D Modeler Materials toolbar, choose vacuum 

Create Region
To create the region:

1. Select the menu item Draw > Regular Polyhedron
2. Using the coordinate entry fields, enter the center position

X: 0.0, Y: 0.0, Z: -100.0, Press the Enter key

3. Using the coordinate entry fields, enter the radius:

dX: 150.0 dY: 0.0, dZ: 0.0, Press the Enter key

4. Using the coordinate entry fields, enter the height:

dX: 0.0, dY: 0.0, dZ: 200.0, Press the Enter key

Segment Number Window

Number of Segments: 12

Click the OK button

To set the name:

1. Select the Attribute tab from the Properties window.

2. For the Value of Name type: Region

3. Display Wireframe: Checked

4. Click the OK button

To turn off the visibility:

1. Select the menu item View > Hide Selection > Active View
To fit the view:

1. Select the menu item View > Fit All > Active View.  
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Create Mesh
Note:  The transient solver does not use automatic adaptive meshing. 

Select Coils

1. Select the menu item Edit > Select > By Name
2. Select Object Dialog, 

1. Select the objects named: Coil, Coil_1, Coil_2, Coil_3, Coil_4, 
Coil_5, Coil_6, Coil_7

2. Click the OK button

To create a mesh:

1. Select the menu item Maxwell > Mesh Operations > Assign > On Selection 
> Length Based

2. Element Length Based Assignment Window

1. Name: Coils

2. Restrict Length of Elements: Unchecked

3. Restrict Number of Elements: Checked

4. Maximum Number of Elements: 16000 (2000/tets per coil)

5. Click the OK button

Select Rotor and Stator

1. Select the menu item Edit > Select > By Name
2. Select Object Dialog, 

1. Select the objects named: Rotor, Stator

2. Click the OK button

To create a mesh:

1. Select the menu item Maxwell > Mesh Operations > Assign > On Selection 
> Length Based

2. Element Length Based Assignment Window

1. Name: Rotor_Stator

2. Restrict Length of Elements: Unchecked

3. Restrict Number of Elements: Checked

4. Maximum Number of Elements: 4000 (2000/tets per coil)

5. Click the OK button
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Analysis Setup

Creating an Analysis Setup
To create an analysis setup:

1. Select the menu item Maxwell > Analysis Setup > Add Solution Setup
2. Solution Setup Window:

1. Click the General tab:

Stop time: 0.05s

Time step: 0.002s

2. Click the OK button

Save Project
To save the project:

1. In an  Ansoft Maxwell window, select the menu item File > Save As.

2. From the Save As window, type the Filename: maxwell_trans_relmotor

3. Click the Save button

Analyze

Model Validation
To validate the model:

1. Select the menu item Maxwell > Validation Check
2. Click the Close button

Note: To view any errors or warning messages, use the Message 
Manager.

Analyze
To start the solution process:

1. Select the menu item Maxwell > Analyze All
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Create Quick Report
To create a report:

1. Select the menu item Maxwell > Results > Create Quick Report
2. Quick Report Window:

1. Select: Current

2. Click the OK button
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Calculate Current
To use the field calculator

1. Select the menu item Maxwell > Fields > Calculator

2. Select Quantity: J

3. Select Vector: Scal? > Scalar Z

4. Click the button Geometry

5. Geometry Window

1. Select the radio button Surface

2. From the list select: Section1

3. Click the OK button

6. Click the ∫ (Integrate) button

7. Click the Number Button

1. Type: Scalar

2. Value: 150 (Number of Conductors)

3. Click the OK button

8. Click the / button

9. Click the Eval button

10. Click the Done button to close the calculator
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